[Resolved] Product Variation no more working

Home Forums Support Product Variation no more working

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #128878
    stardrive

    Dear Tom,

    For a woocommerce product that have size and color variations, when I choose a specific size in the Single Product Details page, I get the following error:
    “Sorry, this product is unavailable. Please choose a different combination.”

    Meanwhile, the product is available. This just started yesterday after upgrade to the latest version of woocommerce.

    Woothemes Mike Jolley has recommended a temporary fix for this (see below). But, I cannot find where in your generatepress theme I will effect the change.

    Mike Jolley Fix:

    “[closed] 2.4 Common Issue – Variations missing on product pages (1 post)

    Mike Jolley
    Member
    Plugin Author
    Posted 1 day ago #

    WooCommerce has a template file called:

    templates/single-product/add-to-cart/variable.php
    Some themes are bundling an older version of this file and will need updating. In the meantime, look for:

    yourtheme/woocommerce/single-product/add-to-cart/variable.php
    And rename or delete the file. This will cause the core WC version to be used in place until the theme is made compatible.

    If you’re unsure if your theme is including this file, view the system status report under WooCommerce > System Status.”

    Please, is there any help you can render here?

    Thank you.

    Regards,

    Stardrive

    #128946
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    We only provide one file for WooCommerce to make it compatible, which is the basic woocommerce.php file.

    GP doesn’t use any custom WooCommerce files when it comes to variable products or anything else, so I’m afraid the above fix doesn’t apply to you.

    Make sure you’re configuring the variable products correctly: http://docs.woothemes.com/document/variable-product/

    #129086
    stardrive

    Thank you, Tom.

    I have communicated this earlier to the woocommerce plugin lead developer, Mike Jolley.
    He found out that it was Magic Zoom plugin that was causing the problem. When i deactivated Magic Zoom plugin, the problem was solved.

    I have informed the developer of Magic Zoom plugin to urgently make his plugin to be compatible with woocommerce 2.4.3

    Meanwhile I must commend your ingenious technique of only providing one file for WooCommerce to make it compatible, which is the basic woocommerce.php file, unlike other themes. This your technique is evidently the best and it makes your theme to always be easily compatible with woocommerce.

    Keep it up!

    Best Regards,

    Stardrive

    #129171
    Tom
    Lead Developer
    Lead Developer

    Good to know a fix is coming!

    Simple is best! That’s the awesome thing about GP 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.