[Resolved] Problemas para configurar las cabeceras mediante “Elements”

Home Forums Support Problemas para configurar las cabeceras mediante “Elements”

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1378937
    Pablo

    ¡Hola!, recientemente estamos implementando el idioma inglés en la web de un cliente y al duplicar la Home/Inicio y duplicar la cabecera creada mediante “Elements” se desconfigura e incluso sustituye la imagen original del logo por otra versión que si se utiliza en otras partes de la web pero no es la utilizada en la versión de la cabecera en español… este problema ya lo habíamos notado en una ocasión que intentamos editar este “elemento” en la versión en español y finalmente tuvimos que restablecer la web porque no encontramos solución… parece ser que ahora, al crear la versión en inglés, este elemento en la versión en inglés genera el mismo error.

    Espero sus indicaciones para resolver este problema. Gracias

    Saludos

    #1379442
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Not sure I fully understand the error – can you link me to an example?

    If the main issue the logo not being correct?

    Let me know 🙂

    #1379460
    Pablo

    ¡Hola de nuevo Tom!, el problema es el cambio de la imagen del logo y la desconfiguración del elemento, tanto al editarlo en español como al duplicarlo para la versión en inglés. Me explico, la correcta es la que aparece en la versión de la web en español ahora mismo (https://www.marialacarbayeda.com/) pero si le hago cualquier edición, quedaría igual que en la versión en inglés de la web (https://www.marialacarbayeda.com/en/), por tanto el problema aparece tanto al editar la versión en español actual como al duplicar el “elemento” para incluirlo en otros idiomas. Espero haberme explicado :). Gracias por tu atención.

    Saludos

    #1379755
    Tom
    Lead Developer
    Lead Developer

    So when you duplicate that Element in another language, it isn’t bringing any of the original settings over with it? It may be worth asking WPML support, as I think they have an option for this. I don’t have a ton of experience with WPML, so I’m not 100% sure what it’s called off the top of my head.

    #1380168
    Pablo

    ¡Hola Tom!, en este caso no creo que se trate de un problema de WPML ya que como te decía, hace un tiempo, cuando no teníamos instalado aun WPML quisimos editar esta cabecera y se nos desconfiguraba exactamente igual que ocurre ahora al duplicar la cabecera para utilizarla en la versión en inglés de la página. Si te fijas, lo que se modifica realmente, es la imagen del logotipo, los espacios que tiene por arriba y por abajo y la altura de la propia “cabecera”… realmente entiendo que es un problema que se ha generado con la plantilla ya que como te comento esto ya ocurría antes de instalar WPML.

    Saludos

    #1380784
    Tom
    Lead Developer
    Lead Developer

    Can you show me a screenshot of the problem so I know exactly what I’m looking for?

    Thanks!

    #1381072
    Pablo

    ¡Hola Tom!, acabo de hacer algunas capturas que espero te sirvan para localizar el error. De todas formas acabo de ver que la URL de la versión en inglés “ha modificado la ruta de la imagen”, me explico, cuando copio la primera línea de código del “element” en español (ya que esta parte del elemento es igual en ambos idiomas) y la pego en el “element” en inglés, al actualizar para que se guarden los cambios, esta URL se modifica y reemplaza la imagen por la que no es, ciertamente es muy extraño.

    Saludos

    https://drive.google.com/file/d/1EOcrmvDTX5rCOuah8eKZwW04RIBnFoTu/view?usp=sharing
    https://drive.google.com/file/d/17f495ZIc4OQ4dNLYw_oQ4Jois6y-5CDD/view?usp=sharing
    https://drive.google.com/file/d/1nYClMyFHeno1ovT_bpIva8BB2BN9w2FB/view?usp=sharing
    https://drive.google.com/file/d/1zNn5XAPZzlXB9zE_vhiif-gdQs75SrXs/view?usp=sharing

    #1381133
    Tom
    Lead Developer
    Lead Developer

    That is very strange – Elements shouldn’t be doing that.

    Perhaps WPML is copying the Element content from another Element? I do think it’s worth checking their support – they’re very helpful and responsive. They may have an idea as to what’s going on here now that we’ve narrowed down the problem.

    #1381397
    Pablo

    ¡Hola Tom!, realmente no, solamente se están utilizando dos configuraciones de elemento y la otra configuración, solo contiene un código para mostrar el título del resto de páginas en la “cabecera” (<h1>{{post_title}}</h1>), voy a consultar con el soporte de WPML… lo único que se me ocurre es que la imagen sea la que esté dando problemas. Estamos en contacto.

    Saludos

    #1382042
    Tom
    Lead Developer
    Lead Developer

    Sounds good – let me know what they say 🙂

    #1386802
    Pablo

    Hola Tom! el soporte de WPML me sugirió recrear lo mismo que tenía en la web en un sitio de pruebas que ellos me pasaron. Instalé la plantilla y apliqué nuevamente la cabecera con “elements”, duplicándola para la versión en inglés tal y como había hecho anteriormente, no se generaba ningún error…

    Finalmente decidí eliminar las 2 imágenes implicadas en el error y eliminar el elemento tanto en su versión en español como en inglés y los creé nuevamente, tras hacer esto todo funciona correctamente por el momento.

    Saludos;
    Pablo

    #1387156
    Tom
    Lead Developer
    Lead Developer

    Glad you got it working! Thanks for reporting back 🙂

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.