[Resolved] Problem using shortcode to access enquiry forms

Home Forums Support Problem using shortcode to access enquiry forms

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1153674
    Richard

    Hi,

    I am using the Bold theme with GP Pro latest version. This uses the free version of Elementor.

    Within one of the Elementor pages of this theme I have tried to add a form using Ninja Forms (free version) which is accessed by shortcode. I am using the basic out of the box default form provided by Ninja Forms rather than create my own.

    The form appears as expected on my web page however when I fill in the details I get an error that it can’t reference the email To field – which in this case would be the email address I have entered on the form rather than the WordPress site admin email address.

    To attempt to find out what is going, I removed the field referenced in the error message so that the enquirer email was ignored and this time the form sent successfully without error. However the email I got back did not contain the form details I was expecting, instead I received:

    hello

    -{field:name_copy_1580754212045} ( {field:email_copy_1580752499063} )

    So the form was able to access my wordpress email address set in settings as I got the email however it appears unable to access the information I entered into the form instead sending the field identities.

    So is the Shortcode element provided as an Elementor element in this theme incompatible – do I need some CSS somewhere to handle the form shortcode instead?

    Note I have temporarily removed the form shortcode from my site as it is live but I can re-instate if needed for a short time.

    Cheers
    Richard

    #1153987
    David
    Staff
    Customer Support

    Hi there,

    instead of using the Elementor Shortcode widget try using the Elementor HTML Widget.
    If there is still an issue then create a new test page without using Elementor and add the Short Code in the normal WP editor – then we can pin down where the issue lies.

    #1158695
    Richard

    Hi David,

    I tried the HTML widget, but gave the same result.

    I noted on the WordPress forums that others have had this issue but Ninga forms don’t seem to have fixed it.

    Rather than waste further time on this I have used WPforms instead which went in as expected and without issue.

    Thanks for your help
    Richard

    #1159167
    David
    Staff
    Customer Support

    Glad to hear you found a solution and thanks for sharing

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.