[Resolved] Preload Key Requests – Performance

Home Forums Support Preload Key Requests – Performance

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1467930
    Enrico

    Hello !

    I did a speed test of my website http://www.lousamagica.com at Google Lighthouse and the performance is bad due to the lack of preloads keys of the icons and fonts of the theme.

    …icons/gp-premium.ttf (4,080 ms)
    …webfonts/fa-solid-900.woff2 (2,550 ms)
    …fonts/eicons.woff2?5.9.1 (2,370 ms)

    Actions I did:

    1) About the icons, I switched to SVG in “General> Icons Type”

    2) On webfonts and fonts, I added a header hook to preload, containing:

    <link rel=”preload” href=”../webfonts/fa-solid-900.woff2″ as=”font” crossorigin>
    <link rel=”preload” href=”../fonts/eicons.woff2?5.9.1″ as=”font” crossorigin>

    I need to know if this is all correct or if I should adjust it otherwise, as I did the test after these modifications and the problem continues.

    Thanks !

    #1468754
    David
    Staff
    Customer Support

    Hi there,

    preloading doesn’t necessarily resolve the issue as it simply means those requests are being made up front. You may want to look at what render blocking requests exist and whether any of those scripts can be deferred.

    I tried running a Page Speed Insight and a GT Metrix test – but both of them failed – complaining that ‘The SSL certificate being used on this website was issued for another website’s address’

    #1469888
    Enrico

    Hi David!

    I’m solving this SSL issue, but for now, if you want to do the tests use this way https://lousamgica.com.br (the problem happens when you use www.)

    Apparently I was not seeing improvements because of cache, but after some time I did the tests again and Google Speed ​​did not return the problem.

    I think it is unnecessary to have to load all the Goolgle fonts, since I use only one (Fredoka One).

    I manage to simplify this loading of fonts by the GP elements panel just as I hooked the preload of the fonts above.

    I have the Autoptimize plugin installed and configured like this:

    “Combine and link deferred in head (fonts load late, but are not render-blocking)”

    But even so, in the tests you will see slowness warnings related to the fonts.

    Are there any actions in the GP that I can take to improve this?

    I appreciate the sharing of your knowledge.

    #1470819
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    GP itself can’t fix this issue – the only thing we can control is how our own icons are served, and you’re already using our SVGs instead of the icon font, which is good.

    The best thing you can do is remove the need for icon fonts at all – not sure which plugin they’re coming from, but it should be possible to disable them and serve your own icons in an SVG format.

    #1480854
    Enrico

    Thanks for the support!

    #1481077
    Tom
    Lead Developer
    Lead Developer
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.