[Support request] Post thumbnail help

Home Forums Support Post thumbnail help

  • This topic has 7 replies, 4 voices, and was last updated 12 months ago by Leo.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1141721
    Ranjit Kumar

    In my homepage or category page, i have set the post to full instead of summary..
    Now when i am going to the category page or homepage only the title is clickable but i want my post to open when someone clicks on the thumbnail
    (In short – i need both title and thumbnail to be clickable to open the post)
    Thanks!

    #1142069
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Since the image that’s displaying is from your content, you would need to link that image manually.

    Alternatively, you can just enable the featured image which links to the post by default.

    Let me know if you need more info 🙂

    #1142226
    Ranjit Kumar

    I choose the 2nd option you gave but after enabling the featured image and set the content type to excerpt everything is showing as I want (but its hiding the share button)
    The only thing I want is the share button should also be shown to the users on the category page (as it is showing when I set the content type of ‘full’ and turning off the ‘featured image’) so that they can directly share anything…
    Let me know!

    #1142680
    David
    Staff
    Customer Support

    Hi there,

    check to see if your Social Sharing plugin provides a shortcode for displaying the share links.
    Then you can add them to Archives using the Hook Element:

    https://docs.generatepress.com/article/hooks-element-overview/

    #1142829
    Ranjit Kumar

    Thanks! David i tried the hook and it is working

    #1142859
    David
    Staff
    Customer Support
    #1144407
    Ranjit Kumar

    Hi David, just looking for quick help regarding a big space in between my theme source code…
    look at the screenshot i.is.cc/DuPqbM.jpg
    (Just press CTRL+U on any post/page you will see this)
    Let me know how to remove this space
    Thanks!

    #1144838
    Leo
    Staff
    Customer Support

    That’s very unlikely a theme issue.

    Have you tried disabling all plugins to test first?

    Any chance you can open a new topic for your question?

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.