[Support request] Pods + Beaver Themer layout – full width not working

Home Forums Support Pods + Beaver Themer layout – full width not working

  • This topic has 3 replies, 2 voices, and was last updated 4 months ago by Elvin.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1508624
    David

    Hi

    I have an issue with a CPT created with Pods for which I’ve created a Themer layout. I’ve added a full-width row to the Themer layout but it’s displaying as if it’s the first sidebar (sidebars are enabled).

    The cause is this piece of CSS:

    .site-content {
    display: flex;
    }

    If I disable this, the row appears full-width as I’d expect it to.

    If I disable the Themer layout for the CPT and enable Beaver Builder with a full-width row, it displays correctly.

    So … not sure if this is an issue between GP and Themer, GP and Pods, or Pods and Themer (although this issue doesn’t occur in Astra, so I’m assuming GP is part of the problem.

    Any suggestions? If you think GP is not at fault I’m happy to raise issues with Beaver Builder or discuss with the Pods folks.

    Thanks!

    #1508644
    Elvin
    Staff
    Customer Support

    Hi,

    Themer layout bypasses the default settings of the GeneratePress. At least up to the theme’s <div class="content-area">.

    While it is true that toggling.site-content { display: flex; } seems to “fix” things., We can do a workaround without having to disable flexbox on the theme’s General Settings found in Appearance > Customize > General.

    Applying this CSS code should do the trick:

    .fl-builder-content {
        width: 100%;
    }

    Any suggestions? If you think GP is not at fault I’m happy to raise issues with Beaver Builder or discuss with the Pods folks.

    I believe Pods shouldn’t affect the layout as it doesn’t do anything layout related. It only controls posts types which is a back-end thing.

    You can raise the issue on Beaver Builder support as well. Perhaps they could give bits of useful information too.

    A wise man once said:
    "Have you cleared your cache?"

    #1508646
    David

    Thanks Elvin

    That’s solved the problem for now … I figured I could disable Flexbox in the Customizer but didn’t want to go that route. This workaround will suffice – thanks.

    David

    #1508653
    Elvin
    Staff
    Customer Support

    No problem. 🙂

    A wise man once said:
    "Have you cleared your cache?"

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.