[Resolved] pingdom.com connection error

Home Forums Support pingdom.com connection error

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #320750
    Jiri

    Hello, I am using generatepress with 4 sites. One of them gets a connection error on pingdom.com.

    It reads: http://samanka.paprsky1.com/wp-content/themes/generatepress/css/defaults.min.css?e0736d.

    It seems that this makes the page to load about 2 seconds longer.

    Does anybody have any idea what it is about and how to solve it?

    Thanks a lot

    Jirka

    GeneratePress 1.3.46
    GP Premium 1.3
    #320801
    Tom
    Lead Developer
    Lead Developer

    That’s an old file that no longer exists in the theme. Maybe try clearing any caching plugins you might have.

    #321081
    Jiri

    Thank you Tom for your answer… The problem is: I have deactivated all caching plugins (i.e. only autoptimize), cleared cache, reactivated, and the issue still persists.

    Any further ideas?

    Thank you very much

    Jirka

    #321265
    Tom
    Lead Developer
    Lead Developer

    Are you using Cloudflare by chance?

    What version of GP are you running?

    #321344
    Jiri

    Hello Tom,

    no Cloudflare. GP with ChildTheme, always the latest versions. My 3 other sites do not have the issue, although all of them are similar – GP with BeaverBuilder, no cache, only Autoptimize, as you have recommended.

    Thank you

    Jirka

    #321468
    Tom
    Lead Developer
    Lead Developer

    Looking at the HTML of your site, it looks like there’s caching/minifying going on.

    If you don’t have any plugins specifically doing that, I would ask your hosting if they do any kind of caching. The way your HTML is makes it look like there’s some sort of Cloudflare-ish service going on.

    #321569
    Jiri

    Thank you, Tom.

    I have ensured, that all optimizing features at A2 Hosting and all minifying plugins are off. Anyway, the issue still persisted. I have created an empty file defaults.min.css through FileZilla and now is the connection error gone. It would be more elegant, if the request for the file could go away, but that ist way too far above my capabilities :-).

    Do you think this kind of solution (empty file) will not cause any harm?

    Thank you

    Jirka

    #321720
    Tom
    Lead Developer
    Lead Developer

    Hmm, that’s a “fix”, but doesn’t deal with the underlying cause that the site is thinking it’s using an older version of the theme. Have you tried asking your hosting support yet?

    #322061
    Jiri

    Hi Tom. No, I have not, but I will and then I´ll let you know. Thanks j

    #322088
    Jiri

    P.S.:

    One more thing I cannot explain: my ex-wife´s computer (this site is for her) does show an old, no more existing version of the starting home page – after clearing all caches, installing new browsers etc. etc.

    All browsers on my computer show the new version.

    This is in some way the same issue: no more existing version is shown – but only on one computer. Maybe this could be a hint…

    Really a confusing issue, I would not believe it is possible, if I would not see it with my own eyes 🙂

    Thanks

    j

    #322320
    Tom
    Lead Developer
    Lead Developer

    That also points to caching. It could be her browser cache, or it could be some sort of server caching you’re not aware of.

    #322765
    Jiri

    Hi, Tom, the answer from my hosting reads:
    ————–
    …if your wifes computer is showing a different version of the site it is entirely possible there is either an entry in her local hosts file on her computer showing an old IP or it is down to caching on the browser. The GTMetrix Reports a 404 error on that file as seen: https://gtmetrix.com/reports/samanka.paprsky1.com/8n0jCeny As this is a down to the “generatepress” theme itself can you please chat to the developers of the theme please and have them confer as to what the issue is with that link. The site itself loads in 1.2 seconds but that URL delays it by 600ms. Please confer with your developer and the theme creators in regards to this issue as this is not a server side issue.
    ——————-
    Thanks for your time, Tom…

    Jirka

    #322897
    Tom
    Lead Developer
    Lead Developer

    Unfortunately there’s not much I can do – the source of your website is cached/minified. You can see this by viewing the source of your site – notice how everything is on a new line, and most of the HTML is on the left side of the screen? This isn’t typical of a regular site that isn’t being cached.

    I tried checking your DNS to see if it’s routing through Cloudflare, but there’s something going on with your DNS as well: http://dnscheck.pingdom.com/?domain=samanka.paprsky1.com

    #323315
    Jiri

    Thank you, Tom.

    One more try, though 🙂 – I have disabled all minifying and chaching plugins again – maybe does the code look better now?

    As far as the DNS is concerned, my hosting tells me QUOTE
    the subdomain does not have the nameservers and it setup with the main domain. The subdomain mainly uses only the IP address and the website points to that IP address. We have checked and can see the subdomain ‘samanka.paprsky1.com’ is pointing correctly to 209.124.67.216
    QUOTE END

    As far as the old, no more existing version of the homepage shown on my ex-wife´s computer is concerned, I have fixed it by deleting a BeaverBuilder cache not only from my computer, but also from her computer. The issue with the non-existent GP-file persists, though.

    My last hope is that you could now see in the code where the request originates from and we would be able to eliminate it. If not, I will perform my “fix” (creating an empty file) 🙂

    Thank you very much

    Jirka

    #323576
    Tom
    Lead Developer
    Lead Developer

    Your source still looks minified/cached unfortunately. There is something going on – if you don’t have a plugin doing it, it has to be your server.

Viewing 15 posts - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.