[Support request] Performance Review in New Site

Home Forums Support [Support request] Performance Review in New Site

Home Forums Support Performance Review in New Site

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1602461
    Kevin

    Hi team,

    I am using GeneratePress on the following two sites

    1. https://morgantechspace.com
    2. https://specrosoft.com

    The first site loads fast and performs well.

    But I have a performance problem in my second site (https://specrosoft.com), the site loads very slow. Can you please review my site and provide suggestions to improve the performance of the site.

    Also, I need suggestions on the plugins that I have used (ex: W3 Total Cache which I have not used in the first site).

    Thanks

    #1602750
    David
    Staff
    Customer Support

    Hi there,

    i ran a GT Metrix and a Page Speed insights report and the second site actually performed better – although in reality both sites take a similar time to load for me.

    Run a GT Metrix report on your site – use the Waterfall report to see if there are significant brown/purple bars – these are generally related to server waiting time. If thats the case you may want to speak with your host as to why there are significant delays. This is a priortiy if your FCP time is high on a Page Speed Insights test – any improvements to FCP will flow down across all the metrics

    #1604341
    Kevin

    Hi David,

    Thanks for your review. I will check with the hosting provider.

    #1604589
    David
    Staff
    Customer Support
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.