[Resolved] Pagespeed is struggling?

Home Forums Support Pagespeed is struggling?

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #343987
    sjoerd89

    Hi there,

    according to pagespeed insights my site is doing horrible.
    I just recently changed my hosting to a premium account what should have made my website a lot faster but according to this tool i am doing much worse. i was at about 85 to 90 on desktop and around 75 on mobile but now somehow it has gone down a lot.

    Any ideas on how to fix this? I am already removing these snippets:
    Removing Emojis
    Removing Query Strings
    Removing Font Awesome

    I have a cache plugin wp fastest cache.

    Have a nice day,

    Sjoerd

    https://developers.google.com/speed/pagespeed/insights/?hl=nl&url=http%3A%2F%2Fwww.zilvertron.com%2F&tab=mobile

    GeneratePress 1.3.48
    GP Premium 1.3.1
    #343993
    David
    Staff
    Customer Support

    I would use

    pingdom

    or

    GT Metrix

    to test your site, gives greater detail. Pingdom shows that there is a ‘broken’ link to the events manager css thats slowing things up as well.

    #343995
    sjoerd89

    Hmmm but still these results are seriously bad,
    for the broken link not sure how to fix that since i do not have the events manager plugin anymore.

    #344015
    Leo
    Staff
    Customer Support

    If you already remove events manager but it’s still showing error then it’s likely a caching issue.

    #344043
    Warner

    @sjoerd89

    There are some other (css related) problems on your site. I.e. the text in the search form on your product pages is cut in half from the top down. This is caused by the WooCommerce Products Filter ext css.

    At the moment the declaration for the searchbox is:

    .woof_text_search_container input[type='search']{
        padding: 9px !important;
        margin: 0 !important;
        width: 100% !important;
        line-height: 0 !important;
        font-size: 14px;
    }

    Note line 4: line-height: 0 !important. The absence of line-height pushes the text up. You can change this by adding the following lines in your custom css:

    .woof_text_search_container input[type='search']{
        line-height: inherit !important;
    }

    I’m not a big fan of using !important everywhere, but for now this should work.

    I also see that you use the All in One SEO pack AND Yoast SEO. Although this is (technically) possible, it is not advisable. Try to choose which one of the plugins you want to work with for SEO purposes and deactivate AND remove the other SEO plugin. A third option is a great lightweight SEO plugin by our fellow Dutchman Sybre Waaijer; The SEO Framework, which you can download for free from the WP Plugin Repo here.

    On top of this, you are using a lot of plugins that offer the same possibilities as GeneratePress does out of the box. You only need to think creativiely and use some custom css. This with the added benefit that you do not need to load Bootstrap into your site’s FAQ page. (Don’t tell Tom you load Bootstrap into GP, he fell in love with Unsemantic a long time ago ;-))

    Kindly,

    W

    #344052
    Tom
    Lead Developer
    Lead Developer

    Those broken links to the Events Manager are adding a lot of time to your load time.

    If the plugin isn’t activated, it means you’re using a caching plugin like Leo mentioned. If you clear your caching, it should improve quite a bit.

    #344353
    sjoerd89

    Thanks for the tips guys! I will try to make some changes.
    Also Warner i have to take a closer look at bootstrap since this is something kinda new to me.
    And i will give the SEO plugin a go.

    Sjoerd

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.