Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Pageheader on blogpage dont work

Home Forums Support Pageheader on blogpage dont work

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #334443
    Mathias

    How i can add a pageheader on my blogpage? I added a picture in the header like my other sides, but if i set the page on blog it dont work.

    https://www.drohnen-flugaufnahmen.de/drohnen-flugaufnahmen-blog/

    #334513
    Leo
    Staff
    Customer Support

    Hi there,

    WordPress ignores all metaboxes on index pages by default (blog, archive etc..)

    You would have to use the customizer options for now: https://docs.generatepress.com/article/blog-page-header/

    The options are exact the same as in the page meta box.

    #337926
    Samu

    Hi!

    I’m trying to add content to my blogpage header via Customizer > Blog > Page header content but it doesn’t show up.

    Also it’s only displaying one single post instead of 10.

    Any idea?

    Thanks!

    #337999
    Leo
    Staff
    Customer Support

    Hi there,

    The options in Customizer > Blog > Page header should work for the main blog page only.

    For single posts you would use the Page Header meta box on each page.

    Let me know if this answers your question.

    If not a link to your site might help.

    #338021
    Samu

    Hi Leo! I figured it out!

    Somehow, a category with the slug “blog” was created so the page I was seeing was the archive for that category, not the blog page itself…

    That’s why I couldn’t see the changes I did in the customizer.

    A post was assigned to that category and that was the only post showing up. I don’t know how that category was created, though. I don’t remember doing such thing. I couldn’t even delete it. I’ve had to change the slug.

    Thanks!

    Samu

    #338044
    Leo
    Staff
    Customer Support

    Glad you figured it out 🙂

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.