Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Page Title Issues

Home Forums Support Page Title Issues

  • This topic has 16 replies, 3 voices, and was last updated 3 years ago by Tom.
Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #289270
    Fin

    When using Beaver Builder plugin, as soon as I activate the builder on a new page, the page title gets moved to the far left/top of the page. I wish to keep the page title where it nicely sits before I enable BB to work on a page, to have show neatly aligned with the rest of the page content. So, I tried using the code below.

    .fl-builder.no-sidebar .container.grid-container {
    max-width: 1280px;
    }

    Unfortunately, this affects the entire site, and I have full-width pages with transparent header and full-width background image on the homepage.

    So…then I hid the page titles in Beaver Builder and added my own titles via the builder. But that generates two ‘h1’ tags per page, because one of them is merely hidden, not removed. Of course, I only want one ‘h1’ tag per page.

    What’s a gal to do?

    The only way around this is if I disable page titles entirely via PHP and add them individually per page via the builder, or choose to hide the titles from pages individually in using the ‘Disable Elements’ feature in GP. It just seems like a lot of work because I still have to add those page titles in myself through the page builder.

    What’s the best way to align page titles with the page content? The website I’m working on is in development, but here’s a link to a sample page: [Removed]

    You can see the two titles. The bottom one I added manually and is how/where I want the top one to appear. I sure hope I’m making sense here.

    GeneratePress 1.3.44
    #289313
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    The next version of GP actually fixes this and makes working with BB much better.

    It’s currently in beta – feel free to email me and I can send it over: https://generatepress.com/contact/

    #289324
    Fin

    Awesome! Thanks Tom! Will send email now.

    #289419
    Tom
    Lead Developer
    Lead Developer
    #419063
    Fiona

    Hi, I am using Elementor Pro and I am trying to Disable Elements “Content Title” on pages. When I do, it sometimes makes my Top Menu inactive. I am using the current version of GeneratePress Premium. I am unable to determine when and why it works occasionally but not on all pages. They have been created the same way, I think.
    Are you able to advise how I can fix this? Thank you for your help.

    #419064
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Can you link me to a page where your top menu is inactive due to the content title being disabled?

    Let me know 🙂

    #419068
    Fiona
    #419069
    Fiona

    Sorry. That was one that is working. Here is one that is not.
    https://www.photohelper.com.au/faqs/

    #419070
    Tom
    Lead Developer
    Lead Developer

    Does your top Elementor section have a shape applied to it? Looks like it’s sitting on top of the menu making it hard to click.

    If you remove that shape, it should work.

    #419071
    Tom
    Lead Developer
    Lead Developer

    Alternatively, you could try using this CSS:

    .elementor-section {
        overflow: hidden;
    }
    #419072
    Fiona

    Yes, I have been seeing if I can use a workaround to cover the content title and moved the shape up. I will move it back down.

    #419074
    Fiona

    I had already removed the padding. It is not showing at my end.

    #419094
    Fiona

    Sorry but where do I put that?

    #419095
    Fiona

    I found it. It seems to have worked. Thank you. I’ll go back and fix the padding on the top shapes now on each page. Was this a glitch in the theme? or something you think I did? as it didn’t happen for every page.

    #419097
    Tom
    Lead Developer
    Lead Developer

    From what I can see, that code should be added inside Elementor to prevent elements from reaching outside of their section. Basically there was an invisible layer created by Elementor sitting on top of the menu making it so you couldn’t click the items.

    Glad you got it working 🙂

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.