[Resolved] Page speed issues even after adding Autoptimize

Home Forums Support Page speed issues even after adding Autoptimize

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1398143
    racheljohn

    First I would like to say I love this theme and how well its supported.
    I am having problems figuring out what I am doing wrong when it comes to page speed/loading time I have installed Autoptimize and set it to your recommenced settings. but my Pingdom speed test is still getting a D 68 Performance Grade any advice would be so helpful.

    #1398504
    David
    Staff
    Customer Support

    Hi there,

    The main issues is the number of requests the site is making. 95 is rather high ( generatepress.com is around 35 ). A large chunk of them are requests to facebook – which i assume is the messenger app. Can you temporarily disable that to check ?

    #1398587
    racheljohn

    Okay so I disabled the messenger plugin for the moment (if you have a better recommendation on how to add messenger I am open to different options) it is a little better but still a Performance grade 75 C on Pingdom so definitely not the whole issue.

    #1398782
    David
    Staff
    Customer Support

    OK – now we only have 44 requests which is great.
    You can remove 1 more by changing the Icon Type to SVG in Customizer > General. Won’t make a huge difference but less requests are good 🙂

    Next biggie is your server is not running GZIP – ask your host to enable this.

    Which plugin were you using for the chat ?

    #1398791
    racheljohn

    Thank you so much for all your help!
    I was using the official Facebook messenger plugin. What would you guys recommend?

    #1399021
    David
    Staff
    Customer Support

    Can’t actually recommend any plugins to replace it – i had a quick look and they all seem to require a lot of 3rd party requests. Which is probably controlled by FB.

    Maybe ask in our FB forum – theres a lot of knowledgable people there:

    https://www.facebook.com/groups/generatepress

    #1399133
    racheljohn

    awesome will check with them also. Just one more question is there a way to add messenger without a plugin? ( my client uses messenger a lot unfortunately)

    #1399859
    David
    Staff
    Customer Support

    Facebook has an API called Facebook Chat Plugin – but thats hardcore custom development.
    I am suprised the Official Plugin was that terrible – i expected it load some JS but that amount of files seems overkill.

    Try re-enabling the plugin – theres a possibility some of those requests were due to a glitch.
    If its still slow – then it would be worth asking on our FB group

    #1402579
    racheljohn

    Thank You So much For your Help One of the Guys on the Facebook Group came up with a cleaver solution using the Flying Scripts plugin deploy the chat a few second later that way its not part of the initial load works great!

    #1402807
    David
    Staff
    Customer Support

    Awesome – glad to hear that and thanks for sharing the solution!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.