Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] Page Header Image doesn't appear in Search Results page.

Home Forums Support Page Header Image doesn't appear in Search Results page.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #181145
    Peter

    Hello,

    First off I want to thank you for creating, and UPDATING, GeneratePress. I was used to creating dynamic websites from scratch but finally gave into WordPress as it’s quicker and cheaper which is what everyone out there wants. ๐Ÿ™‚ Yours is the first theme I’ve used and I really feel lucky that I found it right from the start. GeneratePress seems so clean and flexible that once I wrap my head around it and all-things WordPress, I’m pretty sure I’ll be able to build almost anything! ๐Ÿ™‚

    As mentioned, I’m still wrapping my head around how WordPress etc works. In your plug-in videos, you show the Page Header Images/Content appearing with each blog post in a blog list such as masonry layout. I’m assuming this should work the same on the Search Results page, no? Right now, when I perform a search and get several pages(not blog posts) back, I don’t see any Page Header Image/Content with them. Just the page title and a snippet of the page’s content. If I set an image using the Featured Image option, that image will display too. But setting the image via the Page Header Image option will not display.

    Is this normal behaviour? I would like to see the same behaviour as shown in the video, where images, content and even YouTube videos are displayed with each post on the blog list and search results page.

    Thanks again!

    #181178
    Tom
    Lead Developer
    Lead Developer

    Hi Peter,

    Generally, the Page Header add-on only has the “Show in excerpt” option for the regular post post type – not pages.

    I never thought about the pages displays like posts when you conduct a search – I’m not sure it would be possible to add the Page Header info into the Page excerpts on the search template without some considerable programming and the possibility of really confusing users.

    #181181
    Peter

    Okay, so no to Page Header images in search results for pages. Actually, after doing a test, I’m surprised that no Page Header image shows for posts in search results either.

    I guess I’ll stick to using Featured Images for now. Displaying an image is all I was using the Page Header for at this time anyway.

    Thanks

    #181182
    Tom
    Lead Developer
    Lead Developer

    It should work for posts as long as you have the “Add to blog excerpt” option enabled.

    #181185
    Peter

    Sorry, where is the โ€œAdd to blog excerptโ€ option located?

    I have…

    Customize > Blog > Blog Content > Blog Post Content is set to “Show excerpt”.
    Customize > Blog > Post Image > Post Image is set to “Show”

    … and no Post Header image appears on the Search results page.

    #181203
    Peter

    Wait, I see the “add to blog excerpt” option on my previous test site that still has GP Premium 1.2.79. But on my new test site that has 1.2.80, that option is gone and so are ALL the options from the Content/Content Settings tab. All I have under Content Settings in 1.2.80 is a text field. Is this normal or is something wrong with my install? I also noticed when going to add/edit a page or post, the Page Header section momentarily shows a Video Settings tab and an Advanced Settings tab, but once the page completes loading these tabs disappear. Again, is this normal behaviour or is something messed up?

    Thanks!

    #181240
    Peter

    Ooops… I see the options actually appear if you enter something into the Content Settings field. My bad! haha

    #181334
    Tom
    Lead Developer
    Lead Developer

    No problem! New feature to prevent people from using those options when they won’t do anything ๐Ÿ™‚

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.