[Resolved] No space in left/right side on default editor

Home Forums Support [Resolved] No space in left/right side on default editor

Home Forums Support No space in left/right side on default editor

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2237152
    John

    Hello

    I am facing a strange issue.

    When I create a new post, I see there is blank space on the left and right sides in the WordPress post editor.

    Please check the screenshot https://prnt.sc/k4wU8X-ybbKU

    These spaces are only visible when I create new posts.

    But When I try to edit my previously drafted posts or published posts. There is no blank space on the left and right sides.

    Please check this screenshot https://prnt.sc/hJw5uKnZCRuX

    So It looks messy to me.

    I want to keep blank space on both sides.

    Thanks

    #2237198
    Ying
    Staff
    Customer Support

    Hi John,

    Any chance you can provide admin access to your site and link 2 posts that we can see the different editors?

    Please use the private info field for the login details, thanks!

    #2237401
    John

    Hi Ying,

    Thanks for your response. I have provided all the details, you can check now.

    As I mentioned earlier, Space is only visible for the first time so you can not see the exact issue If I create any posts from my end.

    So, It’s better if you can test by yourself by creating new posts or edit my one of published/drafted posts.

    Thanks

    #2237427
    Fernando
    Customer Support

    Hi John,

    I was able to replicate the issue. Specifically, I created a test Post as you’ve mentioned, and viewed it through editing afterwards.

    Creation: https://share.getcloudapp.com/9Zuo2AXg

    Editing: https://share.getcloudapp.com/8Lu0QJPK

    I’ve placed the post I created in trash.

    As a first course of debugging to see if any of the plugins you have is causing this issue, can you try #1 here?: https://docs.generatepress.com/article/debugging-tips/

    It would be best to take a backup of you site before doing so.

    Kindly let us know how it goes.

    #2237459
    John

    Hi,

    Tried, Deactivated all plugins except GenerateBlocks, GP premium, and WP show posts

    But Still, the issue persists.

    You can check it now. rest of the plugins are deactivated.

    #2237464
    John

    Follow up,

    I have kept my site backup.

    You can do anything(install/remove plugins) to identify the issues.

    #2237486
    Fernando
    Customer Support

    Sorry, I just realized that you have a Layout Element: https://share.getcloudapp.com/YEukmA7B

    When creating a Post, the Layout Element you have that alters the Container width isn’t applied yet.

    Once it’s created, the Contained width value in Layout Element you have set reflects on the Editor. This isn’t a bug. It just shows the look with the max-width set.

    I find it helpful to set zoom out the view of the browser a bit. For instance on mac, press command and – at the same time.

    Alternatively, you may try adding a PHP snippet like this to disable the effects of the Layout Element in the admin/Block Editor Page:

    add_filter( 'generate_layout_element_display', function( $display, $element_id ) {
    	if ( 496 === $element_id && is_admin() ) {
        	$display = false;
    	}
        return $display;
    }, 10, 2 );

    496 is the ID of your Layout Element: https://share.getcloudapp.com/OAu8zbwk

    Adding PHP reference: https://docs.generatepress.com/article/adding-php/#code-snippets

    Hope this clarifies!

    #2237496
    John

    Solved!

    Thanks a lot, Fernando

    #2237501
    Fernando
    Customer Support

    You’re welcome John! Glad to be of assistance!

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.