[Resolved] No se muestran los post de mi blog en la versión en inglés de la web (WPML)…

Home Forums Support No se muestran los post de mi blog en la versión en inglés de la web (WPML)…

  • This topic has 6 replies, 2 voices, and was last updated 2 months ago by Tom.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1377628
    Pablo

    ¡Hola!, estoy implementando la versión en inglés de la web y en el apartado de “Blog” simplemente quería que se mostrasen las entradas en español ya que no se van a traducir y siempre se mostrarían en español. He duplicado la página de Blog para obtener una versión en inglés aunque sin traducción como comento y de esta forma que el menú se mantenga también en inglés. Esto es algo que ya he hecho en otra web utilizando otro theme pero por alguna razón no carga los post.

    Algo parecido ocurre con los post destacados que aparecen en la parte inferior de la home, en la que en la versión en español se cargan 2 post destacados (para esto utilizo el plugin “WP Show Posts”) pero al igual que ocurre en el apartado de Blog, en la Home tampoco muestra estos 2 post destacados (“Sorry, no posts found”).

    Espero que puedan echarme una mano con esto que me está volviendo loco :). ¡Gracias por el soporte!

    Saludos

    #1378221
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    So you want those blog posts to remain in Spanish even when using the English version?

    I believe as long as they haven’t been translated, that should happen by default. However, you may need to confirm that with WPML.

    #1378225
    Pablo

    ¡Hola Tom!, eso es, tanto en la versión en español como en inglés del blog el contenido siempre va a estar en español, ya que los post no se van a traducir, entiendo que si el contenido se duplica para la versión e inglés esto no debería de ser un problema, sin embargo no está funcionando.

    Espero tus indicaciones, ¡gracias!

    Saludos

    #1378570
    Tom
    Lead Developer
    Lead Developer

    If the posts aren’t translated, wouldn’t they display in Spanish by default? Where can I see the issue? Just checked out the Blog page in English but it’s a 404.

    #1378848
    Pablo

    Hola Tom, eso imaginaba, que se mostrarían de manera predeterminada, pero al igual que ocurre en la home, con esos 2 post destacados, por alguna razón que desconozco, no se muestran los post… en el caso del blog en inglés a mi no me aparece como un error 404, simplemente el mensaje dice que no encuentra contenido para el blog (NOTHING FOUND It seems we can’t find what you’re looking for. Perhaps searching can help.)

    Espero tus indicaciones, ¡gracias!

    Saludos

    #1378870
    Pablo

    ¡Hola Tom!, he estado hablando con el soporte de WPML y parece que se debía a un problema en la configuración de las traducciones. En Configuración —> “Traducción de los tipos de entrada” —> Entradas (post), había que marcar la opción “Traducible: usar la traducción si está disponible o recurrir al idioma predeterminado”… activando esta opción se resolvió el el problema con el blog y los 2 post destacados de la portada se mostraron nuevamente sin problema.

    ¡Gracias por tu atención!

    Saludos;
    Pablo

    #1379404
    Tom
    Lead Developer
    Lead Developer

    Glad you got it working! Thanks for sharing the solution 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.