[Resolved] No me admite guardar cambios en el blog.

Home Forums Support No me admite guardar cambios en el blog.

  • This topic has 5 replies, 2 voices, and was last updated 4 months ago by Leo.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1222385
    Rocio

    Buenas tardes.
    Al editar la pagina de contenido del blog, no me guarda los cambios, yo lo he configurado de la siguiente manera:

    Contenido
    Tipo de contenido: extracto
    extracto cantidad de palabras: 10

    Pero me guarda todos los post completos y seguidos unos de otros.

    estos los publiqué con la plantilla Pinacle utilizando Elementor, y allí si que veía el listado de post de forma ordenada.

    Un saludo.

    #1222494
    Leo
    Staff
    Customer Support

    Hi there,

    Looks like you are using Image post type. Not sure if that’s intended?

    If so this PHP snippet is required:

    add_filter( 'generate_show_excerpt', function( $show ) {
        if ( 'image' === get_post_format() ) {
            return true;
        }
    
        return $show;
    } );

    Adding PHP: https://docs.generatepress.com/article/adding-php/

    Let me know if this helps 🙂

    #1223239
    Rocio

    Mi intención es que se vea UN FRAGMENTO de todos los post en la pagina del blog.
    Antes de meter el codigo PHP, ¿estas seguro de que no hay otra solución?

    Me da miedo estar metiendo código PHP porque desconozco el lenguaje

    ¿te podría mandar una foto de como he configurado el diseño de las entradas?

    #1223687
    Leo
    Staff
    Customer Support

    The simple solution would be to use Standard post format instead of Image post format that you are currently using, then the excerpt would automatically kick in:
    https://wordpress.org/support/article/post-formats/

    If you want to stick with the image post format, then the snippet above is required.

    Simple copy and paste with one of these methods should work:
    https://docs.generatepress.com/article/adding-php/

    #1223905
    Rocio

    Mil Gracias, todo solucionado.
    En la plantilla Pinacle los tenia que poner en modo imagen.
    Ya me va todo correcto

    #1223975
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.