[Resolved] No 'Get Started' Button for Site Library – 400 Bad Request Instead

Home Forums Support [Resolved] No 'Get Started' Button for Site Library – 400 Bad Request Instead

Home Forums Support No 'Get Started' Button for Site Library – 400 Bad Request Instead

  • This topic has 9 replies, 3 voices, and was last updated 4 years ago by Tom.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #828983

    In the Site Library, there should be a ‘Get Started’ button as shown in the docs: https://docs.generatepress.com/article/using-the-site-library/

    Instead of that, I see “400 Bad Request”.

    Here is a screenshot of the error: https://imgur.com/a/Bcf1gzU

    I have the GP Premium plugin installed, and I have my key activated to receive updates automatically. This is my first time trying to apply a theme on a fresh install.

    I also have an “A2 Optimized” plugin installed for my hosting provider and “Jetpack” (just the free version). Let me know if there are any known conflicts with other plugins and I can try to enable/disable things if necessary.

    GP Premium 1.7.8
    Customer Support

    Thanks Leo. The A2 Optimization plugin has an “Lock Editing of Plugins and Themes from the WP Admin” option for security, which is a recommended feature. That was actually not enabled when I first started. I tried enabling it then disabling it for a test, and things are getting better but still not completely working.

    Now I was able to see “Get Started” and then “Backup Options”. Those both worked, and I got the backup options JSON file. Then I hit “Import Options” and it gave me the “400 Bad Request” again.

    On a subsequent try, “Get Started” showed up but clicking “Backup Options” led to a “400 Bad Request”. So it failed one step earlier on the second attempt.

    It doesn’t seem like AJAX is completely blocked in the admin pane, as the post you linked suggests. It is having a sporadic error now.

    I will contact the hosting support to see if they can look at error logs to help. If there are any logs I could look at SSH’d in to the system, let me know.

    Thank you.

    Customer Support

    No problem πŸ™‚

    Let us know how it goes!


    FYI – I have a case open with A2 Hosting now for follow-up.

    Their support enabled the PHP error_log configuration option, and added these WP settings:
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);

    However, neither the php error_log or the WP debug.log are ever generated. I reproduced the issue multiple times, and no error file appeared on the filesystem. Whatever error is happening, somehow it is not getting logged.

    I was able to run Get Started -> Backup Options -> Import Options and then Import Content failed. Is there a way to run Import Content on its own? When I go back to the theme now, it tries to start over with “Get Started -> Backup Options -> etc.” again. It does not seem to know that I am already using that Site Library theme, and that I already followed the first several steps.

    Because some steps are working, are you able to see the AJAX requests coming in based on my plugin key? Is there anything visible from your logs to indicate why some requests are working fine and some requests produce HTTP 400 responses?

    Lead Developer
    Lead Developer

    400 responses are almost always an issue with the admin-ajax.php file in your Dashboard.

    It can happen when the security tokens don’t match as well.

    Can you try again after clearing your browser cache? If the option import is working, the content import should as well. It’s ok to re-do the entire import process if you’re importing the same site.


    I tried in an incognito tab to make sure no cache / cookie issues would be present. I got the same behavior. I was able to do Get Started -> Backup Options successfully, then Import Options gave a 400.

    Is there something specific I should look for in my admin-ajax.php file?

    There are several areas where wp_die( ‘0’ 400 ); can be called in admin-ajax.php.

    if ( empty( $_REQUEST[‘action’] ) ) { wp_die( ‘0’ 400 ); }

    if ( is_user_logged_in() ) {
    if ( ! has_action( “wp_ajax_{$action}” ) ) { wp_die( ‘0’ 400 ); }

    else {
    if ( ! has_action( “wp_ajax_nopriv_{$action}” ) ) { wp_die( ‘0’ 400 ); }


    All of those seem pretty clear-cut. I am logged in, and I have the permission for the ajax action as shown by the times where the request works successfully.

    The fact that the requests are working sometimes but not all the time makes it feel like a back-end issue. For extra context, even the Site Library does not load every time I browse there. Often I have to hit the ‘Site Library’ button several times to get the options to load, otherwise it’s just blank. It does not show any error message, just no themes are there to select.

    Are you able to see traffic logs for the successful and/or failed requests hitting your server?

    Lead Developer
    Lead Developer

    In this case, the error is happening before your site even communicates with our server.

    Any chance you can send me temporary admin login details so I can take a closer look?: https://generatepress.com/contact

    If so, be sure to mention this topic.

    Thanks! πŸ™‚


    I wiped my original WordPress install and re-installed without the A2 Optimized plugin. Now, the GeneratePress theme and plugin work reliably instead of sporadically.

    For anyone who finds this thread and is using the same A2 Hosting provider: Installing the “WordPress – A2 Optimized” package causes this issue. If you install the “WordPress + Elementor” package instead this issue shouldn’t happen. It turns out the A2 Optimized plug-in is one of the worst rated in the whole WordPress marketplace, which is pretty disappointing: https://wordpress.org/plugins/a2-optimized-wp/

    Also, for anyone who finds this thread later: please do not give administrative credentials to unsupervised strangers, even temporarily. Offer to set up a screen-share session instead to work together. Giving administrative logins to strangers is generally a very bad idea and should be avoided at all costs.

    Lead Developer
    Lead Developer
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.