[Support request] No Featured Image Post

Home Forums Support [Support request] No Featured Image Post

Home Forums Support No Featured Image Post

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1199151

    Hello All –

    I want to be able to selectively deactivate the display of the featured images on selected posts. In recent days (thanks to Covid-19) I am posting a lot of news updates which all use the same featured image. It is essentially a large square icon. I want this icon to appear in the post listings – to identify the nature of the post – but not at the top of the post itself.

    If this were a page I could disable the featured image – but not with a post. I want the same functionality but I think I am in danger of over-thinking what should be a simple solution…! Should I use a element hook? Should I use ACF? Should I create a new template (the user would then need to select). It all seems over the top when all I want to do is turn off the featured image for a few posts!

    I’d be grateful for a few simple ideas.



    Customer Support

    Hi there,

    in the Post editor you can use the Disable Elements meta box to disable the Featured Image:


    You can also use the Layout Element to do the exact same thing, but you could automate for example by setting the Display Rules > Post Category > Covid Post


    Hi, David –

    The metabox does not appear for Posts. It only ever appears on Pages and CPTs.

    This is the post admin.


    What could be causing this?


    Customer Support

    That’s strange. Haven’t had this issue reported and it should definitely show for posts as well.

    Any chance you can disable all plugins except GP Premium to eliminate conflicts from other plugins first?

    Any other custom functions added? Are you using a child theme?

    Let me know 🙂


    Hi, Leo –

    I have just checked 10+ localhost installations (all different configurations) and none of them show the metabox for posts! I am going to pick one and use that as a test case to see what is causing the problem.

    I never new the metabox should be available for posts!



    Leo –

    Well that was easy. It’s the “Classic Editor” plugin. Without it activated we see this:


    With plugin activated, the metabox disapears!




    Customer Support

    I just activated the Classic Editor plugin and still getting the Layout metabox no problem.

    Is the Layout option checked under Screen Options?

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.