[Resolved] New Font Manager issues

Home Forums Support [Resolved] New Font Manager issues

Home Forums Support New Font Manager issues

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1986920
    Antoine

    Hi,
    I have activated the new font manager on my site (https://faroutride.com/), but I’m having issues with the Typography Manager (customize > typography). If I try to edit any of the existing element (e.g. Heading 1 (H1)), everything just disappear and I cannot access any settings:

    BEFORE I click on an arrow:
    obefore

    AFTER I click:
    after

    I have cleared the browser cache, tried on a different browser, I’m running 3.1.0 theme & GP 2.1.1.
    I’m hosting my font locally per: https://docs.generatepress.com/article/adding-local-fonts/
    “Google Font” is toggled OFF in font manager.

    Thanks for your helps.
    antoine

    #1986944
    David
    Staff
    Customer Support

    Hi there,

    can you temporarily disable all other plugins aside from GP Premium so we can eliminate a plugin conflict.
    IF the issue persists, enter the Customizer, and Right Click > Inspect the page to open the Browser Developers tools and check the Console Tab.

    1. Are there any Red errors on loading the customizer?
    2. Any new errors appear when selecting the Element ?

    If you can provide a screenshot of either then it may give us some pointers on the issue.

    #1986987
    Antoine

    All snippets and plugins are de-activated (except GP premium) and this is the error I still get in the console:
    error

    Thanks
    (p.s. test performed on staging site: https://staging.faroutride.com/)

    #1986995
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Do your fonts in the Font Manager have any variants saved? If not, can you try adding one to each font to see if that fixes the error?

    #1987027
    Antoine

    Thanks for your input.
    Doing as follows solved the issue:
    1- In the font manager, I clicked on the existing imported font (e.g. Roboto Condensed), then enter “Roboto Condensed” in the “Search Font…”.
    2- Then the “Google Font” switch automatically toggled ON, adding a few variants at the same time.
    3- Then I toggled OFF the “Google Font” switch.
    4- I was then able to change the settings (e.g. H2) in the Typo manager (issue solved).

    However, I’m left with one question:
    – What does the “Google Font” toggle switch do exactly?
    – With steps 1 to 4 I did above, am I still using the local font?

    Thanks,
    antoine

    #1987043
    Tom
    Lead Developer
    Lead Developer

    Sounds like we have a small fix to add to prevent an error here. Glad you were able to get it back up and running though.

    1. The Google Font toggle makes the API request to Google to load the fonts.
    2. If the Google Font toggle isn’t enabled, you’re using the local font.

    Let me know if you need more info πŸ™‚

    #1987061
    Antoine

    Awesome, you guys are the best!
    Cheers! πŸ™‚

    #1987097
    Tom
    Lead Developer
    Lead Developer

    Glad we could help!

    One question as we try to reproduce the error – did this happen directly after switching to dynamic typography (migration), or did you tweak something first?

    Thanks!

    #1987100
    Antoine

    It happened directly after switching to dynamic typography, I don’t believe I did anything in between… I do have a bunch of snippets, maybe one of them is responsible of that?
    faroutride mods

    antoine

    #1987351
    Tom
    Lead Developer
    Lead Developer

    Very strange – we’ll see what we can find. Thanks for letting us know πŸ™‚

    #1991084
    Marc

    Installed a new WordPress with GP Premium today and having problems with the new Font Manager too.
    The Console says net::ERR_ABORTED 403 while trying to load the font: https://prnt.sc/1ybluhg

    When I change the font to any other, nothing happens, the page is displayed in the same font all the time.

    I suppose it could be related to Antoines problem, so I added it here…

    cheers, spirou

    #1991170
    David
    Staff
    Customer Support

    Hi there,

    The screenshot shows the font is set set to Georgia which isn’t a Google Font, so you should disable the Goggle font option.
    Let us know if that fixes the issue.

    #1991382
    Marc

    Hi David, sorry, I should have spent a little longer with the new font manager first – I had to choose a font for body first and now I can see the changes. The new font manager seems to take a bit of getting used to, but that’s usually the case with new features πŸ™‚

    thanks again, spirou

    #1991420
    David
    Staff
    Customer Support
Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.