[Resolved] My static homepage isn't working fine

Home Forums Support My static homepage isn't working fine

This topic contains 10 replies, has 2 voices, and was last updated by  Leo 2 months, 1 week ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1196693

    Junaid

    Hi there,

    I just changed my homepage that contained blog posts earlier to a static page. But it’s not working all the time. How can I fix that issue?

    I just want to make it a static page and don’t want posts to appear on it.

    Help me fix and make it permanent.

    #1196699

    Leo Customer Support

    Hi there,

    I’m actually seeing a static page for the home page as you described.

    Perhaps it’s caching issue on your end? Have you tried clearing your browser cache and WP Rocket?

    Let me know ๐Ÿ™‚

    #1196703

    Junaid

    Actually, it’s working fine on Desktop. But the issues are with mobile phone users.

    I have tried to check out on cross browsing app. It’s fine on desktop but not on Smart phones.

    #1196704

    Junaid

    Please check it out using different browsers and different devices. It should work fine on all the devices. But it’s not.

    #1196706

    Leo Customer Support

    Can you disable WP Rocket first and any other caching plugin first?
    https://www.screencast.com/t/cR07inBO7iy

    The front page setting is handled by WordPress itself and the theme doesn’t have the ability to interfere:
    https://wordpress.org/support/article/settings-reading-screen/

    #1196710

    Junaid

    Should I deactivate it permanently? It will increase my site speed.

    #1196713

    Junaid

    Although I have deactivated it.
    The other thing is, I have set is a static page in my WordPress settings that’s why it’s appearing fine on desktop. There is some issue with the mobile version and I think it must be concerned with the theme.

    #1196721

    Leo Customer Support

    I’m still seeing WP Rocket activated. Can you deactivate it from the list of plugins?

    If that doesn’t help, then try disabling all plugins except GP Premium.

    This is definitely not a theme issue – our forum would be flooded with similar topics already.

    It definitely sounds some sort of caching issue to me.

    #1196863

    Junaid

    Ok, I will try to solve it deactivating all the plugins and let’s see what happen.

    #1196864

    Junaid

    The problem was with Lite Speed Cache Plugin. As I uninstalled it’s working fine now.

    Should I not use that plugin?

    #1196895

    Leo Customer Support

    Glad to hear that itโ€™s not a theme issue.

    Using 2 caching plugins would be a excessive in my opinion.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.