Celebrating 7 Years! Get up to $30 off GeneratePress Premium!

[Resolved] My page headers are not showing up

Home Forums Support [Resolved] My page headers are not showing up

Home Forums Support My page headers are not showing up

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #537932
    Karthik Palaniappan

    Hi,

    I had custom headers for each page on my website.

    I logged in after a while and saw that the headers had disappeared. I saw that GP had unified all plugins, and so I wrote to GP support. I have now installed the new GP premium plugin and deactivated the old ones.

    However, I’m still not able to see my custom headers in the various pages. Am I missing out on something?

    Thanks,
    Karthik

    GP Premium 1.6.2
    #537946
    Tom
    Lead Developer
    Lead Developer

    It looks like you’re using the Disable Elements module to disable the featured image, which also applies to the Page Header.

    You can test by deactivating the Disable Elements module in “Appearance > GeneratePress”.

    #537948
    Karthik Palaniappan

    Yes, that worked. So should I just leave it disabled, or is there a setting I need to turn off somewhere?

    Thanks,
    Karthik

    #537952
    Tom
    Lead Developer
    Lead Developer

    You can go into the Disable Elements metabox and de-select the Featured Image/Page Header option: https://docs.generatepress.com/article/layout-metabox-overview/

    #537953
    Karthik Palaniappan

    But do I have to do it for each page/post individually? Or is there a global setting I can change?

    Thanks

    #537964
    Tom
    Lead Developer
    Lead Developer

    You would have to do it individually unfortunately, as it’s a page-specific setting.

    #537968
    Karthik Palaniappan

    ok, I finished it for each page ๐Ÿ™‚ Thanks.

    #538227
    Tom
    Lead Developer
    Lead Developer
    #1457439
    Andrei

    Hi Tom,

    Not sure if it’s oke to write down a message here in this quite old thread, but this is the closest topic I found related to my question.

    I’m glad I found generatepress by the way, I can’t wait to get rid of elementor on my sites.

    However, being new at this, I have the following scenario:

    1. For homePage I’d need a specific hero
    2. For the other pages + all archives, single post, etc I’d need a different hero

    So in the elements section, I made 2 “header” types using the correct exclusions there in the “display rules”.

    But as a result, I’m actually seeing the archives hero on the homePage too, while I don’t see it in the archives at all.

    There’s probably some tricky settings somewhere that I’m missing, so I can hope you can guide me.

    Cheers

    #1457661
    Elvin
    Staff
    Customer Support

    Hi Andrei,

    Can you open a new topic for this? If possible, please include the link to the site as well.

    We’ll make sure to answer it there for you. Thanks.

    A wise man once said:
    "Have you cleared your cache?"

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.