[Support request] Most fonts do not appear on mobile.

Home Forums Support [Support request] Most fonts do not appear on mobile.

Home Forums Support Most fonts do not appear on mobile.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1661283
    usame

    Hello there. I scanned the topics related to the subject, but unfortunately, I am not satisfied. So I might ask again.

    I went into the editor and made the fonts of the titles as Alfa Slab One. I checked it on both mobile and computer and closed it. But as far as I understand, since my android device does not have this font, I am facing a very different font from the one I set on my phone. Did I understand the reason for this correctly? I guess many people using devices like mine won’t see this font when they enter the site.

    On the other hand, I hope that this is not the source of the problem. I wonder your opinion on this matter.

    Thank you. It is a very beautiful theme.

    #1661329
    usame

    Additional edit:

    I have installed “alfa slab one” into my computer fonts before. So I can show the website with this font on the computer. I tried on other computers and saw that it was not “alfa slab one”. I am totally confused now. What is the source of the problem? Is there any solution? My main target is make the website seem different because with the theme and obligations about the speed I am not able to change or use any designed homepage. I have just colors, fonts in my hands. Please help.

    #1661344
    Elvin
    Staff
    Customer Support

    Hi there,

    I’m not exactly sure I understand what you’re trying to achieve.

    It shouldn’t matter if the device doesn’t have the font as long as your site is serving the font file either from locally hosting it or by requesting it from Google fonts.

    I’m not sure how you’re adding/selecting the mentioned font but if I may suggest, try setting it on Appearance > Customize > Typography and select Alfa Slab One from the list as shown here – https://share.getcloudapp.com/rRukjmzR – so the theme requests the font from Google so it could be served to all the visitors of the site regardless if they have the font installed or not.

    Note: Typography may not be available on your customizer settings if you didn’t enable it on your GP Premium settings. You can enable it on Appearance > GeneratePress. More about typography here: https://docs.generatepress.com/article/typography-overview/

    A wise man once said:
    "Have you cleared your cache?"

    #1661352
    usame

    Thank you for your reply.

    I am using autoptimize plug-in. I closed it and the font appeared on all of the devices. I think it is related to this plug-in. Now I am trying to figure it out which option is blocking this font. If you have any idea it will be usefull.

    Thank you.

    #1661362
    Elvin
    Staff
    Customer Support

    Try checking if you have multiple caching plugins. Some hosts like siteground has its own SG optimizer which may be in conflict with autoptimize.

    Try clearing your cache as well and see if the issue still occurs.

    A wise man once said:
    "Have you cleared your cache?"

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.