[Resolved] Mobile theme not showing

Home Forums Support [Resolved] Mobile theme not showing

Home Forums Support Mobile theme not showing

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #245137
    Mark

    Hi Tom

    My desktop site works great wth GP but for some reason that I can’t figure out, the mobile version (I’ve looked on both android and iOS phones) shows a default / non-styled version of the site. I haven’t edited any CSS , just use dthe pro version of the theme. Any ideas?
    (site: https://wwww.markkellyconsultancy.com)

    #245150
    Mark

    Hi – I think I’ve resolved it. I realised that Jetpack > Appearance > Mobile theme option was running. So overruling (as it were) the GP theme. So I just unchecked that option.

    This might catch some others out. Assuming anyone else will make the same schoolboy error I did πŸ™‚
    Mark

    #245207
    Tom
    Lead Developer
    Lead Developer

    Glad you resolved it! Thanks for posting the solution πŸ™‚

    #253448
    Janese

    Thanks for sharing! It helped me out πŸ™‚

    #521390
    Kenny Williamson

    Hi Tom,

    I am replying on this because i have also just noticed that my site has gone off its mobile view.

    I have two sites using generatepress. The one is fine. However, businessowner-cover.com- which was always showing up perfectly on mobile..using mobile on generatepress (not jetpack)i noticed in google search console as not mobile friendly.
    I have already spoken with the hosting company.
    The weird thing is that the site shows up in the customiser fine in the mobile view.

    Yet in firefox, ie and google chrome it is showing what looks like the desktop version. When i switch to the jetpack mobile it shows up fine in mobile (so i suspect it cant be the meta line that i read about somewhere).
    i also tried making the “general” setting in customiser (the csss and dynamic) to off.

    Still no change. The funny thing is this site always used to show up perfectly and i havent added any plugins or anything for a while.

    Just very strange. Not sure if it is some kind of bug, or ineraction with an update on plugin.

    Weird that cusomiser shows, yet browsers dont.

    magiciansandmagic.com and businessowner-cover.com

    #521720
    Leo
    Staff
    Customer Support

    Hi there,

    Can you try #1 here to eliminate plugin conflict? https://docs.generatepress.com/article/debugging-tips/

    If that doesn’t work can you open a new topic and link us to your site?

    Thanks!

    #531162
    Kenny

    Thanks Leo,

    I put this aside, as I was not looking forward to trying to sort this issue out. Luckily, I also had a problem with analytics saying tracking code not complete and one of the devs from Analitify sent me the line with the error.
    It was a prefetch hook that I had missed a “/” in.
    So when the tracking code was corrected, it sorted out the mobile issue, thank goodness.

    #531268
    Leo
    Staff
    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.