[Resolved] mobile menu not working when using http

Home Forums Support mobile menu not working when using http

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #294610
    Han

    Hi Tom, the website gestaltpraktijkarjenhart.nl is working fine, my client is happy. There is one strange thing though: when using http instead of https the mobile menu isn’t working. This is especially annoying because for now a Google search results in a http address (although I persistently have added the https url to Google an via a SEO-plugin).
    Any idea what the problem might be?

    I also noticed that the mobile menu will not close automatically after tapping an item, but only after tapping the close x, is that normal behaviour?

    Thanks beforehand for you help.

    PS I’m using 1.2.91, but will update now 😉

    GP Premium 1.2.96
    #294717
    Leo
    Staff
    Customer Support

    Hi there,

    Looks like you are still on 1.2.91? Can you please update to 1.2.96?

    Are you using a smooth scroll plugin? If so I think that’s what’s causing the mobile menu not working. Updating to 1.2.96 might fix the error.

    Close mobile menu after clicking is also introduced in 1.2.96 so please update.

    Let us know.

    #294736
    Han

    Hi Leo, thanks for your quick reply! I was on 1.2.91, because the auto update failed. Just did it manually. I indeed used a smooth scroll plugin in association with GP Hooks. Disabling plugin and hook helps and the mobile menu now works. Strange though it only was problematic on http and not https …
    Close mobile menu after clicking unfortunately still doesn’t work; any other tip for that?

    #294835
    Tom
    Lead Developer
    Lead Developer

    Which smooth scroll plugin are you using? It looks like it’s using some improper JS which is stopping the GP JS from initiating and closing the menu.

    #295099
    Han

    Hi Tom, the plugin I used was ‘Page scroll to id’ version 1.6.2, in combination with a script I placed in a GP-Hook (After Footer Content and wp_footer). I deactivated it though, as the hook. Just checked and saw that I forgot to disable the wp_footer. Now all works fine! Thanks for putting me on the right track 😉

    #295275
    Tom
    Lead Developer
    Lead Developer
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.