[Resolved] Mixed content

Home Forums Support Mixed content

  • This topic has 3 replies, 2 voices, and was last updated 4 months ago by David.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1505945
    Vranjes

    Hi
    I have errors in sites with the Generate Press theme, and I realized this was due to a plugin. Contacted the plugin author and got his reply which is below. So can you help me to locate the place where the theme uses the mentioned insecure font?

    I have added a link to one post and you will be able to see the error yourself. I have the same error in my other site with the same theme and the same plugin. Thank you in advance.
    Jovo

    These are lines from the plugin’s author:

    “I took a look at your site and if you view the source code of a page on your site you can see that the fonts.googleapis.com is being set in your site header. So it is coming from the theme you are using and not our plugin.

    Since its already being set by your site, our plugin uses it for the font of your I Want This box. You should be able to change it to a secure URL in your theme files. Thanks, Kurt”

    #1506087
    David
    Staff
    Customer Support

    Hi there,

    the only fonts that GP will request are those you select in the Customizer > Typography settings – and i cannot see any theme styling requesting the Oswald font. You can check the Customizer > Typography settings to make sure that none of the elements are set to Oswald.

    The only place i can see that font being used is in the big_block_bottom element which is from your More Here dropdown.

    #1506643
    Vranjes

    Yes you are right, I was able to locate the error, it was in the plugin’s hooks.php file. The plugin’s author could not find it and claimed it was not caused by the plugin.

    So disappointed, I am glad this is not due to your theme. Your help is very much appreciated. I conclude this support ticket.

    I am adding the line of the code with the critical error, just in case somebody else has the same problem.

    echo “<link href=’http://fonts.googleapis.com/css?family=Oswald&#8217; rel=’stylesheet’ type=’text/css’>”;

    #1507055
    David
    Staff
    Customer Support

    Glad to hear you got this resolved!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.