Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Merge Page Header with Navigation no longer works

Home Forums Support Merge Page Header with Navigation no longer works

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #375655
    Alex

    Ever since the Page Headers was moved outside of the Pages area to its own area, I have not been able to merge the header with navigation using an image as the header. I follow the directions per the documentation by:

    1) Having something in content
    2) Enabling “Merge with site header”
    3) Enabling “Place content behind header (sliders etc..)”
    4) Enabling “Custom navigation colors”

    The only way that I can get it to work is if I also enable “Add background image” in the content area. But this does not display the full image, instead just makes it a background. This also does not allow me to have the navigation below the header like I need it to be.

    What am I missing? My site is being developed locally so I can’t send a link.

    GeneratePress 1.4
    GP Premium 1.4.3
    #375672
    Leo
    Staff
    Customer Support

    Hi there,

    The steps haven’t actually changed in the updated in order to merge header.

    Are you using a page builder or not? If you are only using GP then Place content behind header shouldn’t be needed.

    Let me know.

    #382960
    DM

    I cannot get this to work either. I followed all the steps in the video on the add-on for page headers. I can get the logo over the slider and background, but navigation menu will not merge with the logo as shown in your how-to video. help?

    DM

    #382975
    Leo
    Staff
    Customer Support

    Did you follow one of the articles here?
    https://docs.generatepress.com/article/merging-the-page-header-site-header/
    https://docs.generatepress.com/article/merging-header-navigation-content/

    The steps are a bit different depending on if you use a page builder or not.

    If this doesn’t help can you link me to the site? Thanks!

    #395499
    DM

    Thanks! It worked!
    DM

    #395515
    Leo
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.