Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Menus missing on home page when using page header

Home Forums Support Menus missing on home page when using page header

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #379174
    Chad Biggs

    I am using page header for my category pages and everything works good, but when I activate the same page header on my home page, my primary and secondary menus disappear. I am using sections on the home page (not sure if that makes a difference). I am going for the same layout on the home page as the category pages (specialty, water filtration, water softeners). The page header is currently off and the slider is in a section. Any suggestions?

    -Chad

    GeneratePress 1.4
    GP Premium 1.4.3
    #379207
    Leo
    Staff
    Customer Support

    Hi there,

    Can you link us to the page? Thanks!

    #380201
    Chad Biggs

    Here is the link. The page header is turned on and the menus are missing. Here is a link to a category page with the same page header turned on.

    #380441
    Tom
    Lead Developer
    Lead Developer

    I’m seeing this CSS added to your child theme:

    header#masthead.site-header {
        display: none;
    }

    That will stop the header from appearing.

    #380898
    Chad Biggs

    That rule affects all pages including the category pages and the page header still works on the category pages. So why not the home page?

    #381052
    Tom
    Lead Developer
    Lead Developer

    Good question, but the CSS itself should always remove the header. Perhaps there’s something overwriting it on other pages?

    #381227
    Chad Biggs

    I added this and it started working … <embarrassed>Sorry</embarrassed>

    Thank you for your help.

    -Chad

    #381265
    Tom
    Lead Developer
    Lead Developer
    #381366
    Chad Biggs

    Really, I have no idea what the problem is. I decided to dissect the page, so I created a new home page and then created new sections one by one, all exactly the same. By the time the new page was built, the new page did not have the problem with the header or menus as the old page. The weird thing is, it’s doing the same thing on the wamp site as on the live site. I got it working, but I sure wish I knew what the problem was with the first home page.

    -Chad

    #381476
    Tom
    Lead Developer
    Lead Developer

    Did you remove that CSS I pointed out?

    #381576
    Chad Biggs

    No, I was using that rule to push the main menu up on the secondary menu. I didn’t change anything other than the page that everything was on and it started working like all the other pages. Here is the page that is messed up and here is the page that I rebuilt with all the same markup and settings.

    I started another thread here, where I am having issues with the feature images and the page header on all of my post. Here

    #381824
    Tom
    Lead Developer
    Lead Developer

    Ah, it’s not displaying because you have Featured Images/Page Headers disabled in the Disable Elements add-on. If you uncheck that option, it will show up.

    #381946
    Chad Biggs

    It is not ticked and the page header image is being displayed.

    #381988
    Tom
    Lead Developer
    Lead Developer

    On this page: http://kinetico.testbringer.com/home3/

    The image you see is the first section, and the Page Header/Featured Image option is checked in the Disable Elements add-on (I can see the code being added in the source).

    #382066
    Chad Biggs

    You are correct on both counts. I built the page and then decided to use the page header, but wanted to make sure it worked good before I deleted the section with the slider. The Page Header/Featured Image option is checked in the Disable Elements and this is the reason it would not work. Thank you for answering.

    I feel like I have been keeping you guys on overtime. Time to buy you guys more coffee.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.