[Resolved] Feature Image When Using Page Header

Home Forums Support Feature Image When Using Page Header

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #381376
    Chad Biggs

    When I create a post and add a feature image, the image shows up when I view the post, like it should. When I add a page header to the post, the image disappears. When I don’t have the page header turned on and the image is visible, the image stays above the title even when I change it in the customizer to be below the title. Any suggestions?

    -Chad

    GeneratePress 1.4
    GP Premium 1.4.3
    #381420
    Leo
    Staff
    Customer Support

    Hi Chad,

    When you are using page header with content, the Add Background image needs to be selected.

    As for the positioning, are you using the options in Layout > Page Header?

    #381585
    Chad Biggs

    I am using a metaslider shortcode in my page header content. When I tick the add background image the images I am using in the slider repeat horizontally, not a pleasant effect.

    When I create a new page header and insert an image and tick the background image and give it some padding, the feature image still does not display. So it is not because of the slider.

    In the customizer/feature images, it doesn’t matter what setting I use, the feature image does not show if the page header is turned on and nothing changes on any of the settings.

    In the customizer/layout/page header, nothing changes no matter what setting I use.

    I also disabled all of my plugins and changed from my child theme to the gp parent theme and I still cant get a feature image on a post.

    One last thing, all the issues I have been having are the same on my live site and my wamp site.

    #381826
    Tom
    Lead Developer
    Lead Developer

    Can you link me to a page where it’s not displaying?

    #381943
    Chad Biggs

    The Featured Images/Page Headers in the Disable Elements add-on is not ticked. Have a look here

    #381992
    Tom
    Lead Developer
    Lead Developer

    The Page Header replaces the static featured image completely – I assume that’s the issue you’re having?

    #382061
    Chad Biggs

    Yes. When the page header is turned on, the feature image will not display. I would like to have the page header turned on and display the feature image in the content area. Are you saying I can’t have both?

    #382133
    Tom
    Lead Developer
    Lead Developer

    By default, you can’t have both – that’s always been an intended feature of the Page Header add-on.

    You could do something custom like this though: https://generatepress.com/forums/topic/suggestion-page-header-for-pages-posts/page/2/#post-347978

    That way it will add the featured image as well.

    #382150
    Chad Biggs

    I was looking into using a shortcode, but this works good. Thank you.

    -Chad

    #382386
    Tom
    Lead Developer
    Lead Developer
    #382434
    argosmedia

    I have the same issue. Thought it was a bug, but it appears to be a feature. I guess you have your reasons for preventing to have them both, but I see these elements as completely unrelated, and don’t understand why you would should prevent users from using them at the same time.

    I’m glad there seems to be a workaround in the post you mention, I’ll try it out!

    Jurgen Nijhuis - Argos Media

    #382599
    Tom
    Lead Developer
    Lead Developer

    I tend to agree, but unfortunately it’s been this way since the beginning of Page Header, so changing it now would cause too many breakages on sites that expect it to continue working as usual.

    Perhaps an option in the future to include the regular static featured image as well would work.

    #382646
    argosmedia

    Yes, such an option would be great!

    Another page header related thing: it seems to be missing on category archives. There is also no such option in the Page Headers > Global Locations. Maybe that’s also by your choice, but is there a way to show it on all blog related pages instead of only some of them?

    Jurgen Nijhuis - Argos Media

    #382797
    Tom
    Lead Developer
    Lead Developer

    Taxonomy archives are set individually while editing the category/tag etc.. directly.

    There’s no global option for all categories etc.. yet – that is coming soon 🙂

    #382858
    argosmedia

    Ah, thank you! I didn’t know there was a page header option in the category settings 🙂

    Jurgen Nijhuis - Argos Media

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.