[Resolved] Menu Options in Customizer (4.3) Not Saving…

Home Forums Support Menu Options in Customizer (4.3) Not Saving…

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #131016
    Roberto Enrique

    Today I upgraded to 4.3 and I’m realizing that the menu customizer is not saving.

    I mean, I can modify all the add-ons in the customizer without problems but as soon as I edit the menu options (like adding a new item to the menu or modifying an existing one) in the customizer the “Save and Publish” button stops working πŸ™

    I’ve sent login info via email in case you want to see it.

    To reproduce the problem you need to follow this steps:

    • Go to Visit Site
    • Open the Customizer:
    • Try changing/saving add-ons (like typography, colors…)
    • Hit “Save and Publidh”. It should work as expected.
    • Now, go to MENU options in the customizer and try modifying the text or adding a link:

      Now the “Save and publish” does not work neither on the other addons πŸ™

    Thanks in advance.

    P.S.: If I modify the menu through the admin area it works as expected. This problem refers only to Menu options in the customizer

    #131021
    Tom
    Lead Developer
    Lead Developer

    Hi Roberto,

    Almost 1am here so I’m off to bed, but I’ll definitely try it out in the morning.

    Been using 4.3 for a couple weeks and didn’t notice any GP related issues, but didn’t play with the Menu area much.

    Since the Menu feature is brand new in 4.3, there may be some issues. Have you tried Googling it?

    You can also try some of the debugging steps here to see if it’s a plugin causing the issue: https://generatepress.com/knowledgebase/debugging/

    Either way I’ll check it out in the morning πŸ™‚

    #131141
    Tom
    Lead Developer
    Lead Developer

    Just tried this out on my installation – not facing the same issue.

    Any chance you have any plugins installed? Can you try deactivating them all so it’s a completely blank installation?

    #131168
    Roberto BriceΓ±o

    I’ve tried with every browser and deactivating all pulugins but domain mapping because it is just impossible) and the problem is always there.

    I’ve tried also with twentyfifteen and the problem remains.
    I don’t have neither any message in the error log.

    I’ll go deeper tomorrow.

    Thanks. I’ll get back to you then.

    #131260
    Roberto Enrique

    This is not working, I’ve tried also deactivating domain mapping and every other plug-in. Nothing.
    Customizer menu is not saving. I don’t know what to do next πŸ™

    #131263
    Tom
    Lead Developer
    Lead Developer

    Any chance you can try a fresh install of WP in a fresh localhost folder?

    If it remains, it may be worth bringing up to the WP.org core team.

    #131267
    Roberto Enrique

    Thanks Tom, I’m doing that just right now.
    I’m creating a clean installation of wordpress + generatepress + add-ons in a separate folder just to see how it behaves.

    #131274
    Roberto Enrique

    Ok, this seems to be happening only on my multisite installation.
    Keep you informed.

    #131281
    Roberto Enrique

    As this is happening to me only on multisite, and considering you also run a multisite yourself (don’t you) can you please confirm that this is working normally on your end?

    I have three multisites and the problem is exactly the same everywhere, even with twentyfifteen.

    #131430
    Tom
    Lead Developer
    Lead Developer

    Just tried with my multisite installation – didn’t notice any issues.

    May be something you want to post on the WordPress.org site – see if any other developers know what might be going on.

    #131707
    Roberto Enrique

    Sorry if I stress you with this question again,you don’t have to answer if you don’t have the time to do so, I’ll understand.

    Is just that I don’t know where to look for anymore :_-(

    This problem is also happening with a fresh installation of wordpress, so may be this is not related to any plugin or theme but the problem exists on the server side of things .

    The only “rare” stuff I’m doing is that I’m downloading the wordpress package through SSH as suggested here: https://codex.wordpress.org/Installing_WordPress#Detailed_Instructions

    I’m completely lost at this point.
    Can you give me your insight on where to look first in order to diagnose this problem?

    Thanks in advance.

    #131723
    Tom
    Lead Developer
    Lead Developer

    Do you have another server you can test on? If you do, try installing the regular (non-SSH) way.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.