Premium support

Please log in to post in these forums. If you didn't create an account when you purchased, please contact us.

Free support

If you haven't purchased GP Premium, support for the free theme can be found on WordPress.org.

[Resolved] Menu Glich

Home Forums Support Menu Glich

This topic contains 5 replies, has 2 voices, and was last updated by  Leo 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #470226

    Can anyone help me troubleshoot this? For the record, I don’t think this Generate Press related at all, but I’m hoping a smart person (e.g. Tom) can help me diagnose. I’ve started using Advanced Custom Fields and Anywhere Elementor in order to make templates so that I can build a bunch of community pages and still be able to update the template. Before I build any more pages, I need to figure out if this is solvable.

    This is a community page built the regular way of just cloning pages which is a pain in the butt to update.
    https://kimsellstheemeraldcoast.com/destin

    This is by using Anywhere Elementor.
    https://kimsellstheemeraldcoast.com/alys-beach-new-listings/

    When you hit refresh, a quick view of the menu is projected on the left hand side of the page. It’s awful. If I refresh Destin, no such artifact. Is there anyway to avoid this or do I just need to address this with Anand?

    I’ve tried with and without caching.

    GeneratePress 2.0.1
    GP Premium 1.5.6
    #470271

    Leo
    Staff

    Hi there,

    I would recommend checking with Elementor since all the contents and styles are from them.

    I believe it’s something to do with where they load the CSS.

    Want to help support GP? Please consider leaving us a review!
    https://wordpress.org/support/theme/generatepress/reviews

    #470278

    Thanks for looking Leo. I have a line out to them as well. I just don’t know what’s a tough problem or hard one since I lack the experience, but I’m pulling my hair out.

    #470290

    Leo
    Staff

    No problem 🙂

    They should be able to help you out or at least explain it.

    Want to help support GP? Please consider leaving us a review!
    https://wordpress.org/support/theme/generatepress/reviews

    #470346

    Use Autoptimize plugin and configure it to optimize css.

    It happens because while loading template or shortcodes, elementor loads CSS of that part in the footer. This causes a little flash effect as initially it loads with default css and then final css is applied. Autoptimize combined all css files in the page and load it in the head. It will also improve load time of your page.

    Solved!

    #470367

    Leo
    Staff

    Awesome thanks for reporting back!

    Want to help support GP? Please consider leaving us a review!
    https://wordpress.org/support/theme/generatepress/reviews

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.