[Resolved] Marketer 'theme' – missing Navigation Logo functionality (possible bug?)

Home Forums Support Marketer 'theme' – missing Navigation Logo functionality (possible bug?)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #884829
    Leon Rowan

    Hello,

    Personally I don’t particularly need support with this problem, partly because I used a workaround to get past the issue. I thought support/devs should know about it, hence this post. The workaround was drastic however – I had to restore my whole website via my host’s (Kinsta) tools, so I had a fresh copy of Marketer. I did this twice.

    The problem concerns the Customize/Layout/Primary Navigation/Navigation Logo adjustment tool. (Remove/Change Image).

    Please hear me carefully. When I removed the logo, the functionality disappeared! In other words; the Changing Image button worked, but on two occasions (no save involved) when I removed an image I found that the actual buttons disappeared from the customizer. I tried refreshing, saving and some other troubleshooting but that made no difference; I was unable to add a new image because the buttons and section of that panel had gone – the bit between Navigation Search and Navigation Logo Placement. A site restore/fresh clean reinstall of the theme fixed it. (This was yesterday & I quickly ‘solved’ the issue with a restore; so I did not clear cache, disable caching or CDN, nor disable plugins – that said, it didn’t seem like a caching problem or plugin conflict to me.)

    Currently, I have a version of my own logo in situ, which is working fine, so in that sense the issue is resolved. I can still see the Navigation Logo part.

    I am new to GeneratePress and Kinsta, but not WordPress (since 2007), managing websites (since 1999) or IT (since 1981/programming). I’m not an expert but not a noob either (except with GeneratePress and Kinsta). It’s not as far as I can see a ‘noob mistake’ – there does seem to be something wrong somewhere. It’s concerning too because I wonder what else, if anything, might go wrong.

    I hope this helps.

    #884845
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    This is actually intentional in 1.8. Check out the “Navigation as Header” section on this page: https://generatepress.com/gp-premium-1-8/

    We made it so turning the navigation into a header is a one-click process. We’ll be updating all of our sites in the library using the nav as a header to this new option ASAP.

    Sorry for the confusion!

    Let me know if you need more info 🙂

    #884853
    Leon Rowan

    Thanks so much for your help Tom. Great support!

    This explains it: “In 1.8, we’ve removed the Navigation Logo and placement options if you’re not using them, and added a Navigation as Header option. This option will only show up if you’re not using a Navigation Logo.”

    #884860
    Tom
    Lead Developer
    Lead Developer

    No problem! Sorry for the confusion. Hope you like the new option 🙂

    #884869
    Leon Rowan

    I will have a look at the new nav/header option down the track as what I have is OK for now and I have to get the rest of my site moved from my old host (top-tier) – I am having to move it manually, in part because of the problems I had over there – and my new site set up correctly; along with message/marketing changes – the disaster at my last host happened right in the middle of these latter. Lots of work! (I have Elementor Pro also).

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.