[Support request] Malicious code found from GP child theme

Home Forums Support Malicious code found from GP child theme

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1375181
    Richard

    I have been using GP premium but was told to use child theme if I wanted to modify my site. I downloaded the child theme from generatepress’s site. I keep getting malicious code errors from WordFence.

    All my themes and plugins are updated so why do I get this error? Is this normal?

    #1375182
    Richard

    View post on imgur.com

    This is errors I am getting

    #1375292
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That looks like your server was compromised and malicious files have been inserted into various plugins and themes.

    You’ll need to have that cleaned up by your hosting. Once all of the files are gone, you’ll want to make sure all of your passwords are changed/secure. Also, make sure everything (plugins, themes, WP) are up to date.

    #1375316
    Richard

    How could this have happened? I reset my wordpress using WP reset. It happened again and I used wordfence to block.

    #1375371
    Leo
    Staff
    Customer Support

    I would recommend checking with your hosting support and mention to them that this keeps on happening.

    Unfortunately there isn’t anything we can do from our end.

    #1375397
    Richard

    Should I use the child theme if I am editing things from the customization dashboard and through elementor? I am not editing anything in the style sheet.

    #1375613
    David
    Staff
    Customer Support

    Hi there,

    if all your changes are being made within the customizer or the WP Editor or Elementor – then no you do not need a child theme.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.