[Support request] Making The Sticky Menu And Regular Menu Look The Same

Home Forums Support Making The Sticky Menu And Regular Menu Look The Same

This topic contains 7 replies, has 3 voices, and was last updated by  David 2 months, 3 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #1186464



    Apologies for having two support threads so quickly. I cant seem to get my head around this issue with my menu.

    My sticky menu looks great and I would like the regular menu to look the same but I am really struggling to achieve this.

    For whatever reason the site logo wants to always go in the middle of the menu instead of the far left like the sticky menu.

    Header Presets – Current
    Header width – full
    Header container – full
    Header alignment – centre
    Header padding – 40 x 40 x 40 x 40
    Use navigation as header – no
    Mobile header – on
    Branding – logo
    Sticky – on

    Primary Navigation
    Navigation width – full
    Inner navigation width – contained
    navigation alignment – centre
    navigation location – below header (any other setting puts the site logo in the middle of the menu)

    Can you help me set the regular menu to the same layout as the sticky? the sticky looks amazing


    Leo Customer Support

    Hi there,

    I believe the navigation as a header option is what you looking for:

    Can you give it a shot and let me know if that helps?




    Yes, I forgot to mention. Navigation as a header places the site logo in the middle of the menu over the menu items.


    Leo Customer Support

    It shouldn’t.

    Can you activate the option so I can see the issue?

    Thanks 🙂



    It has been changed, please take a look as the site is live.

    Thanks Leo


    David Customer Support

    Hi there,

    This CSS in your child theme is positioning the logo over the navigation:

    .site-branding, .site-logo {
        position: absolute;
        left: 50%;
        -webkit-transform: translateX(-50%);
        transform: translateX(-50%);
        z-index: 200;

    Remove that to cure the issue.



    Fixed. Thank you yet again David. Have a good weekend generatepress staff


    David Customer Support

    You’re welcome – have a good weekend too.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.