Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Main menu displayed in customiser but is gone when the page is displayed.

Home Forums Support Main menu displayed in customiser but is gone when the page is displayed.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #375546
    kerawelt

    Hi support team,

    I’m turning to you because you might help me on a problem I really fail to solve.

    I just started to build a blog website with the Generatepress Theme that’s so much recommended.
    I even installed GP Premium
    I also installed the Elementor builder.

    My problem is that for testing I used one the page templates that comme with Elementor as a Home page, which I have actually set as home page in the Generatepress customizer.
    Then I created a menu which I have set as main menu.
    When I go to Customizer>Layout>Primary Navigation>Navigation location to set the menu position as “over the header”

    Then I get this displayed in the customiser preview BUT without the logo I have set in the customiser.
    Then if I scroll a bit the page in the customiser then I get the logo appears on the side of the menu.

    But the weird thing is that when I save everything I set in the customizer and I exit it the menu is gone !
    Meaning that if I go to Pages and select the Home page for display the menu does not show anymore !

    Any idea of what’s happening ?

    I could give you my credentials for the website if that could help fixing this because my site creation is stalled.

    Many thanks for some help

    Schlomoh

    GeneratePress 1.4
    GP Premium 1.4.3
    #375657
    Leo
    Staff
    Customer Support

    Hi there,

    So something is working in customizer preview but not in live site?

    Can you try clearing and turning off WP Rocket?

    If that doesn’t work can you try turning off all plugins except GP premium and Elementor?

    Let me know 🙂

    #376115
    kerawelt

    Hi Leo

    As you advised me I deactivated all extensions except Elementor, Elementor Pro and GP Premium and it still does not work.

    I’m desperate because I just created a welcome page and a Main menu.
    Plus other empty pages to build the menu with.
    I watched several videos on Generatepress… displaying a menu should be fairly simple.

    Please help me.

    I could give you my credentials including FTP ones if needed.

    Many thanks in advance.

    #376327
    Leo
    Staff
    Customer Support

    Can you link me to the page?

    #376354
    kerawelt

    Hi Theo

    I only partly solved the problem by using the GP Child Theme instead of the child theme I had created.
    Now if you look at this Home page called “Accueil”

    1. The logo appears truncated below the menu and does not appear inside the menu bar until I scroll the page.
    2. Why should the name of the page “Accueil” appear on the page ? Is that normal ?
    2. If I use the Canevas page model provided with Elementor then the menu disappears completely; Is this normal ?

    Please try to help.
    Many thanks inadvance
    Home page

    #376364
    kerawelt
    #376440
    Leo
    Staff
    Customer Support

    1) Looks like right now it’s only set to sticky. Try set it to static + sticky: https://docs.generatepress.com/article/navigation-logo/

    2) Yup that’s the default. You can remove the content title using disable element meta box: https://docs.generatepress.com/article/disable-elements-overview/

    Or remove it by default with this filter: https://docs.generatepress.com/article/generate_show_title/

    3) I’m not familiar with Elementor Canvas. But I believe that takes over all the GP layout from what I understand.

    #376449
    kerawelt

    Many thanks for your help Leo !

    3 last questions

    1. If you look at my site my Logo is stuck to my menu mar. Isn’t it possible to separate it from the menu bar ? I’ve seen this on tutorials but can’t seem to achieve it.

    2. My navigation Logo is truncated at the left side of the menu. Is there a way to correct this ?

    3. Is there a way t have a transparent menu and to change the color of menu items ?

    Great thanks for you help !

    http://www.schlomoh-brodowicz.net

    #376490
    Leo
    Staff
    Customer Support
    #378001
    kerawelt

    Many thanks Leo,

    If you look at my url

    http://www.schlomoh-brodowicz.net

    1. Why is the first item of my menu (“Accueil”) in black instead of blue like the other menu items ?
    2. If you look at the following url

    https://www.virtuallyboring.com/

    You see that a logo appears at the left of the menu upon scrolling.
    But it’s not a Float logo outside container

    This is what I would like to achieve.

    Could you give me some guidance as how to achieve this ?
    Sorry I’m a WP newbie and I know almost nothing about css coding.

    Many thanks in advance.

    #378094
    Leo
    Staff
    Customer Support

    1. That looks like the color selected in Customizer > Colors > Primary Navigation > Background Current

    2. So you are happy with the current header and just want the menu to be next to your logo in sticky navigation?

    #381140
    kerawelt

    Many many thanks Leo

    #381183
    Leo
    Staff
    Customer Support

    You’re very welcome!

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.