[Resolved] Lots of errors, but all the same

Home Forums Support Lots of errors, but all the same

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1210626
    Benjamin

    Howdy. The error log for my multisite on WPEngine is lousy with variants of this:

    [Thu Mar 26 13:51:02.927438 2020] [php7:error] [pid 7222] [client 127.0.0.1:37848] PHP Fatal error: Uncaught Error: Call to undefined method WP_Image_Editor_Imagick::get_error_message() in /nas/content/live/scienceblogcom/wp-content/plugins/gp-premium/library/image-processing-queue/includes/class-ipq-process.php:75\nStack trace:\n#0 /nas/content/live/scienceblogcom/wp-content/plugins/gp-premium/library/batch-processing/wp-background-process.php(303): IPQ_Process->task(Array)\n#1 /nas/content/live/scienceblogcom/wp-content/plugins/gp-premium/library/batch-processing/wp-background-process.php(177): WP_Background_Process->handle()\n#2 /nas/content/live/scienceblogcom/wp-includes/class-wp-hook.php(288): WP_Background_Process->maybe_handle(”)\n#3 /nas/content/live/scienceblogcom/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(”, Array)\n#4 /nas/content/live/scienceblogcom/wp-includes/plugin.php(478): WP_Hook->do_action(Array)\n#5 /nas/content/live/scienceblogcom/wp-admin/admin-ajax.php(190): do_action(‘wp_ajax_nopriv_…’)\n#6 {main}\n thrown in /nas/content/live/scienceblogcom/wp-content/plugins/gp-premium/library/image-processing-queue/includes/class-ipq-process.php on line 75, referer: https://scienceblog.com/wp-admin/admin-ajax.php?action=wp_image_processing_queue&nonce=cfdee3a66b

    Any idea what could be causing it? It hasn’t seemed to impact performance, but it’s been going on a while and I’m in quarantine and all. No time like the present to knock this one off.

    #1210651
    David
    Staff
    Customer Support

    Hi there,

    its due to an issue with the GP Image Resizer that seems to affect a few sites – we’re almost ready to release GPP 1.10 – which actually fixes the issue. If you’re in a hurry then Tom provides a temp fix here:

    https://generatepress.com/forums/topic/image-processing-errors/#post-1143871

    #1210670
    Benjamin

    Great to know. I will wait. Any ETA?

    #1210872
    David
    Staff
    Customer Support

    We’re aiming for an Alpha release today. Generally alpha/beta runs for a week or two.

    #1210905
    Benjamin

    Great.

    #1211669
    David
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.