[Support request] Logo doesn't appear

Home Forums Support Logo doesn't appear

  • This topic has 26 replies, 3 voices, and was last updated 12 months ago by Leo.
Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #1022167
    Hannah

    Hi!

    I have set a picture as my header image and I want to put my logo in the top left hand corner. I have added my logo in the site identity section for both my logo and retina logo but they don’t appear. Please can you help?

    Thanks,

    Hannah

    #1022169
    Leo
    Staff
    Customer Support

    Hi there,

    Can you check if this option is activated currently?
    https://docs.generatepress.com/article/navigation-as-a-header/

    Let me know 🙂

    #1022181
    Hannah

    Hi,

    Thanks for your reply. I just tried that and now the header image has disappeared and the logo has a broken picture icon with the title name, suggesting there is an error with it. So now there is neither the header image or the logo.

    Thanks for your help,

    Hannah

    #1022189
    Leo
    Staff
    Customer Support

    Have you figured out?

    I can see the logo now:
    https://www.screencast.com/t/XvQ0XqDnw4

    Let me know 🙂

    #1022207
    Hannah

    Thank you! I can see it now too. I just need the header image to reappear now too as that disappeared when I activated the navigation as a header. Please could you let me know how to do this?

    Thanks,

    Hannah

    #1022213
    Leo
    Staff
    Customer Support

    Sorry not sure if I understand.

    The header image is generally the logo.

    So you want another image on top of the navigation bar?

    If so you will need to uncheck that option first.

    If I recall correctly, the header wasn’t showing up? Can you make sure it’s not disabled either in the disable element metabox or with a layout element?
    https://docs.generatepress.com/article/disable-elements-overview/
    https://docs.generatepress.com/article/layout-element-overview/

    Let me know 🙂

    #1022218
    Hannah

    Thanks for your reply. I’d like my logo to be embedded over my header image or my header image to appear below the navigation bar (if embedding my logo over my header image isn’t possible).

    I can see when I click on ‘background images’ then ‘header’ the photo I want to see is there but I can’t see it on the website. Shall I uncheck the ‘navigation as a header’ option so that you can see the background image I’m referring to?

    Thanks 🙂

    #1022219
    Leo
    Staff
    Customer Support

    Yup can you uncheck the option for now?

    #1022221
    Hannah

    Thanks for getting back to me quickly. I’ve just unchecked it and the background image has appeared for you to see what I mean.

    Thanks,

    Hannah

    #1022616
    Leo
    Staff
    Customer Support

    Sorry what’s the issue here?

    I can see the background image no problem.

    Are you saying that the logo isn’t appearing even though they are uploaded in site identity?

    Any caching plugin?

    #1022890
    Hannah

    Hi,

    Yes, that’s correct. No, I don’t have a caching plugin. Will getting a caching plugin enable me to see the logo and the background image at the same time?

    Thanks,

    #1022924
    Leo
    Staff
    Customer Support

    That’s weird. The code for logo simply isn’t showing up.

    Have you modified the theme template in any ways?

    What is the logo width set at?
    https://docs.generatepress.com/article/adding-header-logo/

    Can you make sure the customizer isn’t saving the options as draft?

    Let me know 🙂

    #1022948
    Hannah

    Hi,

    It’s set at 160 px. I can’t see where the draft option is in the customizer but it says published at the top. With modifying the template I reduced the thickness of the lines between all the widget so there were only thin grey lines. I also expanded the background image section so that I could see the bottom of the image with the 2 kids in it.

    Thanks 🙂

    #1022964
    Leo
    Staff
    Customer Support

    Weird. The code for the logo simply isn’t showing up at all.

    Can you disable all plugins except GP Premium and let me have a look?

    The background image size is determined by the header padding options.

    Let me know 🙂

    #1022966
    Hannah

    Hi,

    I’ve just deactivated all the plugins except the GP premium for you to now have a look.

    Thanks 🙂

Viewing 15 posts - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.