Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Support request] Lifter LMS and GP Premium

Home Forums Support Lifter LMS and GP Premium

  • This topic has 3 replies, 2 voices, and was last updated 3 years ago by Leo.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #411252
    Keith

    I am using the LMS plugin with Generate Press Premium

    When I select Courses > Courses from the left hand WP Menu and click on Edit a course the screen then does not work like all others.

    The Screen Options drop down on the top right does nothing and I cannot move the widgets around such as Course Builder.(Normal wordpress functionality)

    I seem to be getting a js error on just this page – others are ok

    Uncaught ReferenceError: wp is not defined at widgets.php

    Seems like a conflict but I cant disable the main LMS module…
    I contacted the LMS developer and he reckons the cause is the code in GeneratePress…
    (I tried disabling GP Premium but still get same error)

    GP Premium 1.4.3
    #411413
    Leo
    Staff
    Customer Support

    Hi there,

    Can you try testing with a WordPress twenty-series themes to see if the error still exists?

    Did the LMS developer say what the error is?

    If you search LifterLMS in our forum you will see quite a few posts discussing some issues but I don’t think they are related to yours.

    It might also help if we can see the site as it’s current locked.

    #411431
    Keith

    Hi Leo

    Yes same issue with GP Premium deactivated and theme set to 2017

    So does this mean issue is NOT GP?

    At this point I am not getting a js error BUT if I change back to GP it’s still the same – no js error written BUT cannot move widgets. If I then ADD GP premium plugin – I gte error

    metabox.js?ver=1.4.3:192 Uncaught ReferenceError: wp is not defined(anonymous function) @ metabox.js?ver=1.4.3:192i @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery…:2fireWith @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery…:2ready @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery…:2K @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery…:2

    So GP Premium certainly ‘seems’ to be involved?…

    I can send you login details if you like – as issue is when you login to Admin – how do I send them privately?

    #411541
    Leo
    Staff
    Customer Support

    Yup if it doesn’t work with twenty series theme then it’s not a problem with GP.

    Best to let the plugin author know that you’ve tested with twenty-series theme and it isn’t working.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.