[Support request] issue with adding API key & installing modules

Home Forums Support [Support request] issue with adding API key & installing modules

Home Forums Support issue with adding API key & installing modules

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #2301674
    Aditya

    We have generate press premium registered with email id given in the private box.

    I am trying to add site library to a fresh WP install (so there should not be any conflict issues) & getting this: https://tinyurl.com/23y3xs4n

    Even when I tried to enter the API to get updated, same issue was there. I tried it in gap of 2-3 hours still same issue.

    Can you pls let me know why is this issue? and what I can do to get the needful done & move ahead?

    Thanks

    #2301753
    David
    Staff
    Customer Support

    Hi there,

    1. Make sure you site server has no caching or Cloudflare enabled.
    2. In Settings > Permalinks, make sure the structure is set to default, and click save changes to Regenerate the Permalinks which should also kickstart the REST API.

    Give that a try, if the issues persist, when viewing the GeneratePress page, Right Click > Inspect the Page to open the browser developers tools, and then click the Activate Site Library. Are there any errors in the developers tools console tab ?

    #2301763
    Aditya

    Hi David,
    Thanks for your reply.

    1. I guess I am not using any caching yet
    2. Its already set to default.

    I have shared the website & WP dashboard SS with you in private.

    I am sorry I didn’t get the other instructions you shared:
    Give that a try, if the issues persist, when viewing the GeneratePress page, Right Click > Inspect the Page to open the browser developers tools, and then click the Activate Site Library. Are there any errors in the developers tools console tab ?

    #2301825
    David
    Staff
    Customer Support

    With #2 still click the Save Changes, what this does is regenerate the sites permalinks and kickstarts the REST API, which may just fix the issue.

    Try that,

    #2301897
    Aditya

    still not fixed, recorded a video – shared in private.

    #2301912
    David
    Staff
    Customer Support

    In your video in the Settings > Permalinks, at the bottom i see this:

    https://www.screencast.com/t/1HnFbaBaK

    So there is an error with your HTTAccess rules. Can those rules be reset to default on your install ? Your host should be able to assist with that.

    #2303049
    Aditya

    David, namecheap’s team looked into it & now they are saying the issue is from theme’s side.

    Where should I go now to get the issue resolved & focus on my actual work?

    Pls support.

    #2303066
    David
    Staff
    Customer Support

    Can they explain why it is an issue with the Theme ?
    Is it a blocked IP ?
    Did they fix the HTTAccess errors ?

    #2303108
    Aditya

    David, issue resolved by the namecheap team.
    Thank you so much 🙂

    #2303118
    David
    Staff
    Customer Support

    Glad to hear that! Do you know what the issue was ? It may be useful for other users

    #2303163
    Aditya

    Yes, sure.

    Earlier there was some issue with the installation that time the website URL was kept to https://www.domain.com/

    To fix the issue it was needed to reinstall the WP & at that time website URL was kept to https://domain.com/

    That is what was causing some conflict.

    #2304055
    David
    Staff
    Customer Support

    Thanks for letting us know !

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.