[Resolved] Issue while importing from site library

Home Forums Support Issue while importing from site library

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #952319
    Vish

    Hi

    I tried to import the Marketer site library theme into a fresh WordPress installation.

    It got imported successfully but I do not see the text (excerpt) and read more button in posts on the home page.

    Before importing, the text is fine and visible.

    I tried this in multiple new WP installation. Still, no luck.

    No other plugins are active. No cache or optimization – nothing. Just a fresh WP installation.

    Could you please help? Have included the site URL.

    #952345
    Leo
    Staff
    Customer Support

    Hi there,

    Strange.

    Is the content type set to Excerpt here?
    https://docs.generatepress.com/article/blog-content-layout/#archives

    And the excerpt word count is not 0?

    Let me know 🙂

    #952350
    Vish

    Leo – Big thanks for the quick response 🙂

    Actually, it is the first thing I checked. And no, it is not zero. It is set to 20. And also ‘Display read more as button’ is also enabled.

    I tried to compare the source of my site and gpsites.co/marketer side by side and see the following differences:

    In the demo, after the entry-summary class there is <p></p> and read-more-container both are missing in my installation.

    In gpsites.co/marketer:

    <div class="entry-summary" itemprop="text">
    				<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc imperdiet rhoncus arcu non aliquet. Sed tempor mauris a purus porttitor, … </p>
    <p class="read-more-container"><a title="The Fastest WordPress Theme" class="read-more button" href="https://gpsites.co/marketer/2018/09/08/the-fastest-wordpress-theme/#more-21">Read more<span class="screen-reader-text">The Fastest WordPress Theme</span></a></p>
    			</div>

    In my site:
    <div class="entry-summary" itemprop="text"> </div>

    The content is not even coming in the source code at all. I have used marketer several times before without any issues (as recent as a week ago) but now it’s just not working.

    I’d be happy to share the credentials to the site if you’d like to take a closer look.

    Edit: So, I thought my hosting might be an issue. So, I created a dummy sandbox (clean WP install) and installed GP and GP Premium and imported marketer there as well.

    The SAME issue there too. Here’s the dummy sandbox URL: http://unusual-cow.w6.poopy.life/

    Is there something unusual going-on with the SiteLibrary setup?

    #952427
    Leo
    Staff
    Customer Support

    Hey I just tried importing and the same thing happened to me.

    I’m not sure why though but have forwarded to Tom.

    He will have a look and get back to you 🙂

    #952437
    Vish

    Wonderful thanks. I was breaking my head over this for over 3 hours, trying to figure out the issue.

    Actually, most of the site library sites are affected by this bug, if I am not wrong.

    Looking forward to the fix!

    #952464
    Tom
    Lead Developer
    Lead Developer

    It looks like the “Excerpt” metabox is being imported with a bunch of empty spaces. If you remove those spaces, it should go back to normal.

    I’ll fix this issue at our end ASAP.

    Thanks!

    #952566
    Tom
    Lead Developer
    Lead Developer

    This should be fixed now. I only found the issue in Marketer – let me know if you ran into the same issues with other sites.

    Thank you! Appreciate the heads up 🙂

    #962954
    Vish

    Thanks, all good now 🙂

    #963051
    Tom
    Lead Developer
    Lead Developer
Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.