[Resolved] Is there some way to allow Thrive Landing page templates work on GP premium?

Home Forums Support [Resolved] Is there some way to allow Thrive Landing page templates work on GP premium?

Home Forums Support Is there some way to allow Thrive Landing page templates work on GP premium?

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #503143
    John

    New user of generatepress premium here. I want to use GP in combination with Thrive architect as it is my favourite page builder, however, now I notice that I can’t seem to use the thrive architect landing page templates (very useful for building sales pages and squeeze pages). Tried searching here for an answer to this problem but cant find any which I find weird as it is one of the most popular page builders. Can someone advise of a workaround (if any)? Thanks in advance for help.

    GP Premium 1.5.6
    #503166
    Emil Moldovan

    Hi,
    I am a GP Premium user,too, and I have the exact same problem. I didn’t open a separate thread because it didn’t make sense. I posted here just to let the guys from GP support that you are not the only one having this issue. Looking forward for the solution.
    Thanks,
    Emil

    #503197
    Emil Moldovan

    Hi again,
    I’ve found a way but it’s not related to GP, it’s a Thrive Architect workaround.
    1. I’ve opened a TA landing page, saved each section with everything in it as a Content Template (there were only 4 on the Upside Down Home page for example)
    2. I’ve reverted the page to the theme default
    3. I inserted the 4 content templates I’ve saved one after another. Done
    Execution time around 5 minutes. Not the most elegant solution, but not bad after all.
    I’m still open to other better options.
    Cheers,
    Emil

    #503362
    Tom
    Lead Developer
    Lead Developer

    I’m not super familiar with Thrive. What’s the exact roadblock you’re both running into?

    #503421
    Emil Moldovan

    Hi Tom,

    Thank you for jumping on this.
    Thrive Architect has a lot of useful Landing Page templates, which can be loaded from the TA menu after you start editing a page/post in TA. But, when you load a Landing Page, that Landing Page takes over the whole page, it doesn’t limit itself to the container/area below header. That means you have a page without the default website’s header. That is ok for some landing pages, but not ok for a lot of pages. For most of my pages, I want to be able to have the header of GP Premium and to load the TA Landing Page templates strictly in the are below header.
    I hope I described the problem clear enough.
    Thanks again.
    Cheers,
    Emil

    #503575
    John

    Hi Tom and Emil,

    Thanks for responding. I made a quick video of the issue with Thrive Architect pre made landing page not working with generate press theme. View video here https://cl.ly/0Q2z1V312S27

    Apologies for the incessant mumbling! I hope I got the issue across properly! I am quite surprised that this issue has not been flagged before. While Generatepress is awesome for the main site and blog, Thrive architect pre made landing pages is awesome for making the quick squeeze and landing pages. If both can work together, then you have a great combo…

    #503593
    Emil Moldovan

    Hi John,
    It looks like I have a different problem than yours. Sorry for hijacking your post. What I want to say, though, is that for me what you were trying to do works in GP Premium + TA. Landing Pages from TA load properly and take over the whole page. So it may be something related with your setup, maybe other plugins interfering, or other issues specific to your website.
    Cheers,
    Emil

    #503630
    John

    Emil, thanks for the heads up. Interestingly, I disabled all the plugins except GP, TA and it worked! Then I enabled the other plugins again one by one to find the problem one but alas, I couldn’t replicate the issue!

    I hope you find an answer to yours. We can close this issue now. Thanks all

    #504258
    Tom
    Lead Developer
    Lead Developer

    Emil – that might be a question for Thrive then. I assume there should be a way to use their templates within the default theme template, so the header/footer is still available.

    Perhaps using a shortcode?

    #504701
    Emil Moldovan

    Hi Tom,

    Yes, I’ll ask the guys at Thrive about my issue.
    Thanks.
    Cheers,
    Emil

    #504899
    Tom
    Lead Developer
    Lead Developer

    No problem – let me know if there’s anything I can do 🙂

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.