[Resolved] Invalid license on lifetime license

Home Forums Support [Resolved] Invalid license on lifetime license

Home Forums Support Invalid license on lifetime license

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #2393718

    Hi folks,

    I’m trying to update to the latest version of GP Premium (2.2.0), but I’m being told my license is invalid. It’s a lifetime license, so I know it hasn’t expired.

    I’ve gone into settings and deleted the license that was in there and re-pasted it from the downloads section of this site, but still no dice. I have another WP installation on the same server and that seems to be working fine, so it’s not a license issue. It also can’t be a firewall issue, as the other site is working fine.

    The issue is the same on my staging site, so I disabled all plugins and tried again, still didn’t work. If you guys have any ideas, I’d love to hear them. I’ve included my license and staging site details in the private section, so feel free to login and make any changes you like in there.


    Customer Support

    Hi there,

    Ok, thats an odd one. Any firewall or other security mods on the server ? Can the host check the server can reach generatepress.com


    Like I said, the other site on the same server works just fine, so it’s definitely not a firewall/server issue.


    Just SSH onto my server to double check, just to rule it out definitively:

    # wget https://generatepress.com
    --2022-10-30 15:40:19--  https://generatepress.com/
    Resolving generatepress.com (generatepress.com)...
    Connecting to generatepress.com (generatepress.com)||:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: ‘index.html’
    index.html              [ <=>                ] 121.95K  --.-KB/s    in 0.1s    
    2022-10-30 15:40:19 (1.20 MB/s) - ‘index.html’ saved [124872]
    Lead Developer
    Lead Developer

    I just tried your license key on my test server and it worked fine.

    Are you sure there are no other characters/spaces being pasted into the field when you paste it? That’s the only reason why you’d be getting an “invalid” error that I can think of. You can test this by checking out the value in the database after you save it – it should appear exactly as you pasted it with no trailing spaces.

    Let me know 🙂


    Nope. I checked that – pasted it into a text editor first.

    Lead Developer
    Lead Developer

    Can you check the value in the database and make sure it saved correctly without any changes to any of the characters?


    Oh my goodness, I’m such an idiot!

    I was pasting the key into the GenerateBlock key field, not the GP key field. I’m so so sorry for wasting your time guys; now I’ve pasted it into the correct field, it’s all working.

    Lead Developer
    Lead Developer

    No worries at all! Glad it’s all working 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.