[Support request] Installing theme from site library

Home Forums Support Installing theme from site library

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1154250
    Arjan

    Hi, I thought that after downloading the theme (in my case Broadcast) from the site library my site would look the exact same. However, the only thing that is the same is the format of the heading and the footer. But I only have a Sample page and a white box (with “Hello”) covering part of the heading. Was my assumption not correct or am I doing something wrong?

    #1154403
    David
    Staff
    Customer Support

    Hi there,

    can you try importing the site again and make sure on step 2 that the checkbox is enabled and the Import Content button is clicked:

    https://docs.generatepress.com/article/using-the-site-library/

    #1154414
    Arjan

    Thanks for your prompt response.

    I did so again, but have the same issue. What else should I try?

    #1154468
    Leo
    Staff
    Customer Support

    Can you confirm that you are using the latest version of GP Premium 1.9.1 and WordPress version 5.3.2?

    We had a similar bug before but it should have been fixed.

    Any errors when you click import content?

    Let me know 🙂

    #1154872
    Arjan

    Yes, I can confirm that. I downloaded everything over the last week.

    No errors when I click ‘import content’.

    #1154901
    Arjan

    Here are the detailed steps I have taken to create a new website and test it again:

    1. Create new database using MAMP;
    2. Download latest version of WordPress and move the unzipped folder to Applications > MAMP > htdocs, which already contains two folders from other sites and where I keep my ‘gp-premium-1.9.1’ file;
    3. Change the name of the WordPress folder into the name of my new database;
    4. Change DB_NAME (‘name_of_database’), DB_USER (‘root’) and DB_PASSWORD (‘root’) and save as wp-config.php (remove the sample file);
    5. Go to http://localhost:8888/name_of_database and complete set up;
    6. When I view the site I see the ‘Hello World’ template of WordPress with the Sample Page;
    7. In Appearance I install the free GeneratePress theme and activate it;
    8. In Plugins I upload the ‘gp-premium-1.9.1’ file from the htdocs folder, install it and activate it;
    9. When I view the site I still see the Sample Page (see step 6), but now in the GeneratePress format;
    10. In Appearance > GeneratePress I activate the Site Library (nothing else);
    11. In the Site Library I select the Broadcast template and view the Details;
    12. I click ‘Importing Options’, check the box ‘I understand that this step will add …’ and click ‘Import Content’;
    13. When I view the site I still the Sample Page (see step 6), but now in the Broadcast format.

    #1154925
    Leo
    Staff
    Customer Support

    Hey! I appreciate the testing 🙂

    I just tried it on a new install and got the big white hello world box plus the sample content:
    https://www.screencast.com/t/s7w2RMSH

    Do you have a live site with this issue that we could do some testing?

    Is it just the sample content that’s missing?

    I can send you the content file is you give us a shout using Account Issues as well:
    https://generatepress.com/contact/

    Let me know 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.