[Resolved] Importing library site breaks my site – “the page redirects incorrectly”

Home Forums Support Importing library site breaks my site – “the page redirects incorrectly”

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1349866
    Anton

    I have a couple of Generatepress-sites, so I have imported and played around with the framework for some time.

    I have a new site now where I wanted to add a library site. However, it breaks the site.

    The issue is with step 2 in the process of adding a demo/library site. Adding step 1 “alternative for theme” is fine, the site looks strange – but still works. It’s when I import “theme content” that the site stops working.

    I get this error message (translated with Google translate):

    “the page redirects incorrectly

    An error occurred while connecting to mysite.com.

    This problem can sometimes occur if you disable or refuse to receive cookies.”

    – I have the latest versions of the theme + premium plugin
    – I have disabled all plugins (including cache)
    – I’ve checked the SSL cert

    Generatepress works fine and other themes, as well. But it’s when I important something from the library that it gives me this error about redirect.

    I’ve tried importing “Dev” and “Vinyasa” demos. Several times. I have also used the “delete the imported website”-function.

    Any ideas what could be wrong here? I will now leave the site with a demo imported, so that you can see the error message.

    Thanks in advance.

    Anton

    #1349871
    Anton

    I have also installed Simple SSL plugin. Still not working.

    It’s as if the themes try to redirect somewhere that it shouldnt.

    #1349916
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    That’s strange, there definitely shouldn’t be any redirecting.

    Where are you seeing this error? Can you show me a screenshot, maybe?

    #1350125
    Anton

    Hi Tom,

    I get the same error as everybody else when trying to enter my website: https://i.imgur.com/0zminLG.jpg

    #1350770
    Anton

    Hi guys,

    Since the website is new and only had one article on it, I decided to delete the application and re-install WordPress.

    Now everything works perfectly fine. So I guess there must have been an issue with the WordPress installation/previous themes and not Generatepress.

    Thanks guys.

    Have a nice weekend

    Anton

    #1350838
    Tom
    Lead Developer
    Lead Developer

    Strange – glad it’s working now! 🙂

    #1446944
    Anton

    Hey guys,

    I had the same issue once again.

    After a couple of hours of headache, I contacted Cloudways support and they found the issue. When I added the domain to the server, I wrote the first letter in capital letter – like this: Domain.com

    Simply changing it to “domain.com” from “Domain.com” and clearing the cache solved this whole mess. No more re-directs errors. I.e this issue had nothing to do with the theme.

    Thought I’d come in and write it here, in case someone else gets the same issue.

    All the best!

    #1447421
    Tom
    Lead Developer
    Lead Developer

    Thanks for reporting back! We appreciate it 🙂

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.