[Resolved] Image when sharing

Home Forums Support Image when sharing

  • This topic has 10 replies, 2 voices, and was last updated 1 year ago by Leo.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1213159
    Gabriel

    Hi, something weird is happening here: https://vancouverleaders.ca/
    When I first shared the link to the website on different social media platforms – specifically on LinkedIn, the first image on the page was picked up together with the link – that is the big logo from the first section.

    Then, without changing anything, somehow it skipped this one and it takes the second photo, which is my photo. Can someone please help me fix this? I’d like either to be able to choose which photo it shares or to stick to the first one, as it did at the beginning.
    Thank you!
    Gabriel

    #1213214
    Gabriel

    Update: I installed yoast seo after reading about a possible fix with this, but I can’t find where to set the image for the frontpage…

    #1213269
    Leo
    Staff
    Customer Support

    Hi there,

    YoastSEO or any SEO plugins should have this option.

    I believe the Social tab in the YoastSEO is what you are looking for:
    https://www.screencast.com/t/7Fg6BXbSq

    If not it might be best to check with their support.

    #1213331
    Gabriel

    Thank you, Leo! My yoast doesn’t look like this…I don’t see that option – is it the premium version? I only have the free one.
    Thanks

    #1213332
    Leo
    Staff
    Customer Support

    Nope I’m using the free one as well.

    Just to double check, my screenshot is taken from a metabox which is inside the Edit page screen.

    #1218790
    Gabriel

    Hi Leo, please tell me where exactly is this screenshot, I can’t find it…Thanks!

    #1218857
    Leo
    Staff
    Customer Support

    It’s under the Edit page or Edit post screen for each page/post.

    Maybe something like this would help?
    https://yoast.com/help/yoastseo-meta-box-missing/

    If not then it might be worth checking with their support.

    #1218881
    Gabriel

    It’s just not there…However, I was hoping for a native solution inside generate press, not with an outside plugin. Is there one?

    #1218882
    Leo
    Staff
    Customer Support

    Unfortunately not.

    Things like these are always handled by an SEO plugin.

    Here is where the metabox is showing up for me:
    https://www.screencast.com/t/CYoBqsL3N1

    #1219780
    Gabriel

    I still can’t figure this out…Can I have other opinions/solutions on this? Apparently this issue is mostly with LinkedIn. Thank you!

    #1219865
    Leo
    Staff
    Customer Support

    Unfortunately anything to do with social networking is handled by an SEO plugin.

    Maybe give RankMath a shot? I’ve heard good things about it as well.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.