[Resolved] Image logo not actualized on the homepage while I changed it in the customiser

Home Forums Support [Resolved] Image logo not actualized on the homepage while I changed it in the customiser

Home Forums Support Image logo not actualized on the homepage while I changed it in the customiser

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #247607
    David

    Hi,
    it’s very strange. I changed my image logo in the customiser (Site identity panel). The new image is in place on every page of the website, except on the homepage where it is still an old image.
    More this old image was deleted in the media library.
    Doing the setup several time, the homepage finally didn’t display any image (just the missing image icon). I had to upload via ftp the old image in the my uploads folder to have a displayed image on my homepage. But it’s the old one,that is still not visible in the media library (logic because ftp upload).
    It seems my theme or wordpress installation is unable to actualize the image link for the homepage.
    See there: https://www.chateaucanteloup.fr

    I though to activate another theme and reactivate GPress but I fear to loose settings and time that goes with this.

    Any idea to fix this?

    David

    #247713
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Nice site!

    Checking out your homepage, I’m seeing the same logo as every other page: http://www.screencast.com/t/dQKc9s87

    Did you get this sorted?

    Let me know 🙂

    #248563
    David

    Hi Tom,

    The logo seems to be the same, but the files are different.
    On the homepage, I still have the old image with a non secure url (http://www.chateaucanteloup.fr/wp-content/uploads/2016/10/Logo-CPC-white-nobkgd-1.png) and I have the good and secured image on all the other pages (https://www.chateaucanteloup.fr/wp-content/uploads/2016/11/Logo-cpc-hp.png).
    As I told you, I choose this second image in the Customiser but it doesn’t refresh the homepage…

    #248696
    Sebastian

    Hi David,

    I looked into the source-code and it shows in the header:

    <div class="inside-header grid-container grid-parent">
         <div class="site-logo">
    	<a href="https://www.chateaucanteloup.fr/" title="Château Prieuré Canteloup" rel="home">
    	    <img class="header-image" src="http://www.chateaucanteloup.fr/wp-content/uploads/2016/10/Logo-CPC-white-nobkgd-1.png" alt="Château Prieuré Canteloup" title="Château Prieuré Canteloup" />		</a>
         </div>
    <nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="site-navigation" class="main-navigation">
    	<div class="inside-navigation grid-container grid-parent">
     	   <div class="site-logo sticky-logo">
    		<a href="https://www.chateaucanteloup.fr/" title="Château Prieuré Canteloup" rel="home"><img class="header-image" src="https://www.chateaucanteloup.fr/wp-content/uploads/2016/11/Logo-CPC-white.png" alt="Château Prieuré Canteloup" title="Château Prieuré Canteloup" /></a>
    	</div>

    If the site-width is smaller than 768px and the menu/header changes to mobile/sticky, the correct https logo is loaded. If screen size is bigger than 768px than the wrong logo is loaded.

    Have you set the logo up anywhere else in the customizer or on another place. Maybe you have to update the logo image after switching to https?

    You can set up a logo image in Customizer under “Website information” and “Layout > Main navigation”. Have you took a look in this locations?

    #248730
    David

    Hi Sebastian,

    I just find the reason. I overwrited the customizer setup in the page header setup of the homepage. I can’t remember when I did that (I just didn’t remember you offer this option) and I didn’t saw it because the preview was white and transparent on the white background of the page.
    Sorry for the mistake and thank you to help me think.
    :o)

    #248783
    Tom
    Lead Developer
    Lead Developer

    Awesome, glad you were able to figure it out 🙂

    #427819
    Joshua Vandercar

    Thanks for tracking this down! I was just encountering the same thing. Glad to find this thread!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.