Cyber Week Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] I should've never touched Page Header after update. It borked my site.

Home Forums Support I should've never touched Page Header after update. It borked my site.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #381368
    Jenness

    I created a few different page headers and was messing around putting different ones on different pages. Then I wanted to go back to the way it was, made sure the blank page header was on all Pages, but there are some things now stuck. I tried deleting all the Page Headers. No joy.

    http://www.thegreencheetah.com Look at the header…
    This shouldn’t have a background… I deleted it in customizer.
    It shouldn’t have a tag line… I deleted all my Page Headers.
    Now the featured image isn’t showing on ANY of my Pages (should be under every one and they’re all gone). It still shows the featured image added, none of the elements are disabled, in the Edit Page.

    I tried changing the theme to Twenty Fourteen, and Twenty Sixteen, and then back to Generate Press. No joy.

    Help!

    GP Premium 1.4.3
    #381477
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I’m not sure I understand.

    1. According to your page source, your home page has a Page Header set. Do you have any Page Headers set in the Global Locations area? If not, is there a Page Header set in the Page Header meta box while editing that specific page?

    I’m seeing you’re using a caching plugin – can you clear your cache, then deactivate the plugin for now?

    2. Which pages lost their featured images?

    #383473
    Jenness

    1. I don’t have any page headers set in the global locations area. I don’t have anything selected in the page header meta box because I deleted all the Page Headers trying to fix it. I cleared my cache.I deactivated the caching plugin.

    2. All pages lost their featured images. There is a featured image chosen in the box on every page that exists.

    I’d be happy to give you temporary admin privileges privately if you tell me how to get them to you.

    #383478
    Tom
    Lead Developer
    Lead Developer

    1. Can you go into the Global Locations and hit the save button? There’s a bug currently where if a Page Header is unpublished or deleted, GPP will still try to use it. Re-saving global locations will tell GPP to stop (this is fixed in the next version).

    2. GP can’t remove set featured images – that would require it to loop through each one of your posts (big no-no), and manually delete the option. 1.4 definitely didn’t do that. Were you using the Featured Image meta box, or the Page Header meta box to upload your featured image?

    #384120
    Jenness

    1. THIS FIXED IT! JOYJOYJOY! All my Featured Images are showing on each page. The header background is now empty and the tagline is gone. Exactly what I wanted. Now I’m going into Customizer to put it back but it feels good knowing it’s now there because I put it there. OR… I’ll use the Light version of my logo instead of the Dark version. We’ll see. The important thing is IT WORKS!!!
    2. I am using the Featured Image meta box.

    I do want to create different Page Headers and choose them in the Page Header Meta Box on a case by case basis but now I’m a little leary of that. We’ll see.

    Thank you so much for helping me!

    #384211
    Tom
    Lead Developer
    Lead Developer

    No problem! This bug is fixed in the next version 🙂

    #389163
    Nick

    I’m still having this problem 🙁

    I’m using the latest version of GPP and I have deleted all page headers, nothing is selected in Global Locations and I have re-saved it (clearly, since they’re all deleted) and nothing is chosen on the page either.

    Any ideas what I can do? It’s not a live site (http://simardsnippets.com/sample-page/) that I really care about but I was setting things up to make a video about how to do something cool with page headers, and now it’s all stuck.

    As a test while writing this I created a new page header and made that one global everywhere as well as chose it in the page and the OLD ONE is still showing up on the friggin page. AND, I even disabled the header altogether in Disable Elements and the damn thing persists.

    Help?

    #389450
    Leo
    Staff
    Customer Support

    Hi there,

    I’m not seeing a page header on this page? http://simardsnippets.com/sample-page/

    Let me know.

    #389459
    Nick

    Hey Leo. That top bar with the social icons and the menu, that’s the page header. When I deactivate GeneratePress Premium it goes away.

    #389463
    Leo
    Staff
    Customer Support

    That’s all Elementor content?

    #389466
    Nick

    It’s an Elementor section shortcode inserted into a page header. It shows up on every new page I create, which is only possible if it’s the page header doing it. It’s very bizarre.

    #389479
    Leo
    Staff
    Customer Support

    Uhh I’m not seeing any page header code or GP code on that: https://s26.postimg.org/ezkvabj9l/2017-09-21_0825.png

    What happens when you deactivate Elementor?

    #389482
    Tom
    Lead Developer
    Lead Developer

    Yea, if it was in Page Header, there would be specific elements with classes surrounding it.

    Maybe it’s in GP Hooks?

    #389489
    Nick

    Weird! Not at a computer at the moment but I’ll check when I get back. Thanks guys!

    #389526
    Nick

    Aaaahhh…GP Hooks. Duh. I don’t even remember doing that, haha. Guess that’s what happens when you jump back into something that you started hastily a week ago. Thanks guys!

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.