[Resolved] I messed up my off canvas panel because of w3 cache plugin.

Home Forums Support I messed up my off canvas panel because of w3 cache plugin.

  • This topic has 5 replies, 2 voices, and was last updated 2 months ago by David.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1376284
    Subarnamoy

    I don’t know much about websites. So I was trying out all the settings in w3 total cache plugin. I was able to increase website loading speed from 6 seconds to 2 seconds, but I messed up the off-canvas panel which I was able to customize with the help of the support team. I tried different settings but I am unable to resolve this issue.

    Customized settings BEFORE the installation of w3 total cache –
    1) hamburger( with toggle label) option was on the right side of the navigation bar with padding on both sides of the hamburger option and toggle label. It was created with the help of a hook element and custom CSS.

    Now, I somehow messed up whole off-canvas panel

    Problems –

    1) Off-canvas pannel is showing below the footer
    2) hamburger option is not visible, only toggle label is showing on the right side of the navigation bar

    I don’t know why this happened. So will you be able to tell me some pointers about custom cache settings? I like to set the cache setting in a way that the custom CSS will not be affected.

    #1376702
    David
    Staff
    Customer Support

    Hi there,

    first thing to do is to disable the cache and see if it is the problem.
    Once done so re-enable it and disable the Combine/Minimize CSS settings and see if that resolves the issue. If it does then let us know. And we can take a look at what can be done.

    #1376771
    Subarnamoy

    hellow,

    W3 total cache was creating the issue. I disabled all the CSS minify settings. Now the off-canvas panel is working properly.

    In minify CSS settings I ENABLED the following commands –

    1) CSS minify setting was enabled ( i disabled “combined only” option)
    2) Preserved comment removal was enabled
    3) Line break removal was enabled
    4) HTTP/2 push was enabled

    I like to increase website speed, so is it possible to set CSS in a way that I am able to retain the website speed without affecting the custom CSS?

    #1376968
    David
    Staff
    Customer Support

    If it was only the Combine option that was the issue, have you tested the site speed with and without it enabled. If you’re server is running HTTP2.0 then you may notice it is quicker without the combined CSS.

    #1377073
    Subarnamoy

    okay, thank you very much for your assistance. Now the website speed is good.

    #1377525
    David
    Staff
    Customer Support
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.