[Resolved] I am trying to change my header background color, but it's not working

Home Forums Support I am trying to change my header background color, but it's not working

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1113600
    Richlyn

    Hi All,

    I have been trying to change the color of my header according to this article https://docs.generatepress.com/article/colors-overview/.

    Both the backgrounds and color add ons are activated. When I click on colors, then header, I only have the option to change the color of the site title.

    Under “More header controls,” there’s 1) layout 2) Typography and 3)Backgrounds

    When i click on “backgrounds” it skips, and takes me to “background images” and there’s no option for me to change the background color of the header.

    Please let me know what I need to do to change this.

    Thanks so much.

    #1113927
    Leo
    Staff
    Customer Support

    Hi there,

    This is what you should see in Colors > Header when the Colors add-on is activated:
    https://www.screencast.com/t/N2txpoqsFMUn

    If that’s not what you are seeing, can you disable all plugins except GP Premium to eliminate any unknown conflicts?

    Let me know πŸ™‚

    #1114058
    Richlyn

    HI Leo,

    I deactivated all of my plugins and its still not working. It still only shows “Site Title” and nothing else.

    Thanks

    Richlyn

    #1114095
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    You’re using your navigation as your header (https://docs.generatepress.com/article/navigation-as-a-header/), so the header colors won’t show (as they won’t work).

    Instead, you can change the navigation background color.

    Let me know if you need more info πŸ™‚

    #1114099
    Richlyn

    Hi Tom,

    Thanks for your reply. You are correct. I saw that I am using my navigation as a header. I have the generate press Marketer theme.

    I followed your advice and it still doesn’t work. It seems like there’s a glitch here or something. Everytime I click on “backgrounds” to customize the background it doesn’t provide me any options to do so. It just skips straight to “Background Images” with no option to change the color.

    I click on 1) customize, 2) layout, 3) header ( the “use navigation as header” is checked)

    Before that I see “more header controls” that have the options of “colors, typography, and backgrounds”.

    I click on the “background” option from under this menu “more header controls” and this is what takes me to “background images”. so it looks like this (customizing>background images)

    I don’t know what else I can do to make this work besides uninstalling the theme and trying again.

    Please let me know.

    Thank you.

    Richlyn

    #1114111
    Richlyn

    Hi Tom,
    I finally figured it out. I went under colors and clicked “primary navigation” and was able to change the color from there. Thank you.

    Richlyn

    #1114552
    Tom
    Lead Developer
    Lead Developer

    Glad you got it sorted πŸ™‚

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.