[Support request] How to remove white space top of page built with Elementor Page builder

Home Forums Support How to remove white space top of page built with Elementor Page builder

  • This topic has 23 replies, 9 voices, and was last updated 11 months ago by Randy.
Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts
  • #353821
    Matt Singh

    I am working on the homepage right now using an Elementor template and I’m ending up with a white space at the top of the page. I don’t know anything code so please go easy on me.

    GP Premium 1.3.1
    #353833
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Can you link me to the page?

    #353845
    Matt Singh

    I am building it on a local MAMP server.

    #353850
    Leo
    Staff
    Customer Support

    Hard for us to tell without seeing the site.

    Any chance you can reproduce the issue on a live server?

    #353857
    Matt Singh

    I can do that, but it will take me a while to get things in order. Later today if I get a chance. Thank you

    #353970
    Matt Singh

    Ok, I’m taking a different tack. I created a new website with GP premium and Now I want to eliminate the header on the main page. I did some searching and found a Post where you recommended installing this CSS

    .site-header {display:none}

    I used the customizer > Additional CSS. I can see that that it got it installed by viewing the Page source just before the </style></head> tags. Unfortunately, it had no effect on my header.

    I will work this evening on getting my stuff up on a server that you can access. In the meantime any comments?

    #354091
    Leo
    Staff
    Customer Support

    Is it a GP header or Elementor header?

    Using the Disable Element meta box should also work: https://docs.generatepress.com/article/disable-elements-overview/

    #354103
    Lyle

    Matt –

    To remove the white gap at the top of your Elementor created page, in the very top section, set the Column Gap to No Gap 🙂

    Cheers!
    Lyle

    http://snifflevalve.com
    Tutorials and tips for GeneratePress, WP Show Posts, WordPress and Elementor

    #354113
    Matt Singh

    I am trying to use GP premium as a framework for Elementor Page Builder. I’ve only just started and I’m working on my first page, which is a homepage. The page I created had a band of whitespace above the first section that I couldn’t get rid of, so I just deleted the whole project and started over again. I’m not sure what I did now I don’t have the white space so I’m good to go.

    Just for curiosity sake, I would still like to know how to get rid of the header on the homepage in GP.

    #354117
    Leo
    Staff
    Customer Support

    The Disable Element meta box should work: https://docs.generatepress.com/article/disable-elements-overview/

    If not then we will need to see the site to see why it isn’t working unfortunately.

    #489704
    alzate1985

    Hello Leo,

    I have the same issue, but I don’t want to make everything from the start to solve the problem. Can you please help me? http://inkster.online/

    Thank you!!

    #489928
    Leo
    Staff
    Customer Support

    Setting the header padding to 0 here should remove the white space for you: https://docs.generatepress.com/article/header-padding/

    Please open a new topic if that doesn’t solve it. Thanks!

    #506560
    David

    I’m having the same issue, can’t seem to get rid of the extra white space at the top of the page. I tried changing the Header padding to zero but nothing changed. I want to remove the space on all pages but here’s the page I’m specifically working on right now:

    https://photographyworkshoptravel.com/home-2

    #507063
    Leo
    Staff
    Customer Support

    Looks like you’ve solved this? http://www.screencast.com/t/6Vki6ZI0Ouh

    If not please open a new topic for your question.

    Thanks!

    #507156
    David

    I did kind of figure it out on that 1 page. In the Layout section, I just disabled:

    Top Bar
    Header
    Secondary Navigation
    Featured Image / Page Header
    Content Title

    So not exaclty sure what did it. Is there a way to make every page default to this so I don’t have to go into each page and change those settings?

Viewing 15 posts - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.