[Resolved] How to create one empty page

Home Forums Support How to create one empty page

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1349334
    Marcel

    Hi,

    I’m trying to create one page that’s completely empty (so no footer, header, menu’s etc) and only containing the content I add.

    It almost seems to work by switching off (in page settings) Layout – Elements all off and sidebars off, footer widgets off, etc.

    It looks fine except on mobile you get the header and menu (in portrait mode, when you turn to landscape it disappears).

    How to get this done?

    Kind regards,

    Marcel.

    #1349639
    Marcel

    I added the URL to staging, I’m planning to go live this evening (Amsterdam, NL timezone) so I hope there is a solution before that 🙂 (otherwise if staging is not available anymore just remove the subdomain).

    Kind regards,

    Marcel.

    #1349672
    David
    Staff
    Customer Support

    Hi there,

    did you disable both the Header and the Primary Navigation?
    If that doesn’t work can you try disabling them using the Disable Elements metabox in the post editor:

    https://docs.generatepress.com/article/disable-elements-overview/

    #1349754
    Marcel

    Hi David,

    thanks for your support, indeed as written:

    “by switching off (in page settings) Layout – Elements all off and sidebars off, footer widgets off, etc.”

    I switched everything off but still only on small devices the header and menu appears.

    Kind regards,

    Marcel.

    #1349760
    David
    Staff
    Customer Support

    Did you try this:

    If that doesn’t work can you try disabling them using the Disable Elements metabox in the post editor:

    https://docs.generatepress.com/article/disable-elements-overview/

    If that doesn’t work – can you check you’re using the latest version of GP and GP Premium ?

    #1349842
    Marcel

    Sorry David,

    I see it’s very extremely busy here at the forum for you, but you ask me twice the same and I answer twice the same: yes I did.

    I have the latest version as I just bought it.

    Kind regards,

    Marcel.

    #1349911
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Hard to tell without seeing it, but maybe it’s the mobile header that isn’t being removed?

    If so, try this:

    .page-id-xx #mobile-header {
        display: none;
    }

    Just update xx with the ID of the page.

    #1350394
    Marcel

    Hi Tom,

    Thanks for your time and help, also this code doesn’t work, strange isn’t it?

    I added the PROD URL so you can have a look. So only on small screens it shows.

    Kind regards,

    Marcel.

    #1350478
    David
    Staff
    Customer Support

    Ooops…. sorry about that
    Try this:

    @media (max-width: 768px) {
        .page-id-72252 #mobile-header {
            display: none !important;
        }
    }
    #1350508
    Marcel

    WOW!! This was THE code!!!

    Thanks David!!

    Kind regards,

    Marcel

    #1350751
    David
    Staff
    Customer Support
Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.